CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ICEM] ICEM 2D -> Fluent (

Ralen May 5, 2012 05:18

ICEM 2D -> Fluent
1 Attachment(s)
The geometry is very simple for example. I tried to do two different ways:
1. Create a sketch in SW, fill it and import in ICEM, they create a grid.
2. Created in ICEM geometry of points and they create a grid.
Choose the solver Fluent V6 and save the output cyl2d.msh by selecting 2D.
In ICEM create 2D Planar, and then do as in the case of 3D. Am I correct to create a 2D mesh in ICEM?

Choose 2D & parallel Fluent. In both cases, displays a message:
Error: Failed in Fill_Domain.
Note: It is possible that this case or mesh file needs to be first
processed by the serial solver. To do this, please read
file into the serial solver and then save it. Next,
read saved file into the parallel solver.
MPI Application rank 0 exited before MPI_Finalize() with status -1073741819
Error: Build Grid: Aborted due to critical error.
Error Object: #f
The Parallel FLUENT process could not be started.

According to the recommendation choose serial. In both cases, displays a message:
FLUENT received fatal signal (ACCESS_VIOLATION)
1. Note exact events leading to error.
2. Save case/data under new name.
3. Exit program and restart to continue.
4. Report error to your distributor.

PSYMN May 6, 2012 18:02

Associate Edge to Curve
1 Attachment(s)
You did not associate your edges to your curves.

In ICEM CFD, associating edges to curves causes line elements to be created in the part name of the curves. When you send the mesh to Fluent, these are used as the boundaries.

Usually, I would expect to see a "null pointer error" or something like that... But I just associated the edges to the perimeter curves and it worked...


Attachment 12947

Ralen May 7, 2012 00:39

I just do not always associated the straight edge. Usually, they are automatically associated. :confused:

PSYMN May 7, 2012 09:49

No, they are aligned because the edges are straight and the boundaries are straight, but that is not the same as associated... For 3D, it only matters if you smooth (because aligned nodes stay on the feature curves), but for 2D it is critical for creating boundaries.

Fluent 14.5 has had a slight improvement in that it now has a much better error message when you have this problem that should get you going in the right direction much more quickly.

Ralen May 8, 2012 01:15

3 Attachment(s)
In the first project I only associated the edges and renamed SOLID in FLUID. Solver for Export - Fluent V6.
Fluent: k-epsilon, in - velocity inlet, out - pressure outlet. Initialize with X Velocity 10 or 100.
1. Air 100 m/s
2. Water Liquid 10 m/s
If I increase the number of nodes from 80 to 1000 (the minimum mesh size is ~ 1e-5 m) and set Settings->Model to 1e-14, then I get that on the third picture (Water Liquid 10 m/s).

PSYMN May 8, 2012 10:02

This is a highly unstable flow. If you try to solve with a steady state solver, you will never get the same thing twice, even with the same mesh...

Try solving as transient.

Ralen May 8, 2012 10:56

With a large grid more likely to get the result on the unsteady flow? And then, if the first two cases, the results appear as intermediate steps of unsteady solution, in the third there is no solution.

dearali911 May 10, 2012 13:43

i m the former gambit user .
i found icem totally different ,, can any body give ma kind of toturials about quadratic meshing

PSYMN May 10, 2012 15:41

ICEM CFD is very different to Gambit, but like gambit, it generates linear mesh.

There is a mesh editing option (add midside nodes) if you want to turn the mesh into quadratic mesh. You can do this with straight sides or you can have the mid side nodes project to the surfaces and curves...

As for tutorials... Check the customer portal. Actually, there are even some built into the help system (already in ICEM CFD), depending on your version.

Ralen May 11, 2012 02:14

1 Attachment(s)
Air 10 m/s
Transient at 0.2 s
80 nodes (linear mesh law ~0.001 - 0.00013) Turbo viscosity Under-Relaxation Factor 1 by default
1000 nodes (linear mesh law ~0.0001 - 0.00002) Turbo viscosity Under-Relaxation Factor 0.1 for the convergence of solution.

Far May 11, 2012 03:50

What type of problem you are experiencing?

Ralen May 11, 2012 05:32

Wrap the tube bundle. In the meantime, a very simple task to learn.

PSYMN May 11, 2012 09:00

Ralen, that second solution gradient looks a lot like the mesh... Probably not a good sign.

Far May 11, 2012 09:32


Ralen, that second solution gradient looks a lot like the mesh... Probably not a good sign.
Sign of line elements? in other words flow is not going inside

PSYMN May 11, 2012 09:41

No, I mean that you can clearly see the Ogrid shape around the cylinder in the second picture. If the result gradient flows the mesh that closely, it is usually a sign that your mesh is significantly influencing your results.

You could test this out by adjusting your mesh a little (pull the edges in or out, or adjust the distribution) and you will see a large difference in the result, even with the same solver settings.

Usually, when I see this sort of result gradient jump along a blocked edge, it is due to a jump in mesh size. Using match edges or smoothing the mesh should help.

Ralen May 14, 2012 07:12

1 Attachment(s)
In previous example with 1000 nodes minimum size is 0.00002. On 1000 nodes (linear mesh law ~0.0001 - 0.00001) I get the same picture.

Then I increased the number of cells in the other direction from 41 to 410. The cell size is 4e-5*1e-5 instead of 4e-4*1e-5.
No errors where there are no small cells.

So in the flow cell is less than 1e-4 m highly undesirable.

All times are GMT -4. The time now is 06:25.