CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ANSYS Meshing] Issue with modeling dynamic capillary rise in a capillary tube (

cp703 February 27, 2013 16:56

Issue with modeling dynamic capillary rise in a capillary tube

I'm not sure if this is the right spot for this question, but I think my problem is related to my ANSYS Geometry setup step. I'm a real novice using ANSYS (specifically I'm using FLUENT for fluid flow). Prior to getting started on a bigger project, I went through a lot of the tutorials provided by ANSYS and then wanted to set up a simulation that has some of the same physics going on (mainly, capillary forces are dominant in fluid flow) but is very simple. So after some searching, I found a paper published by C. Kurt Svihla and Hong Xu entitled "Simulation of Free Surface Flows with Surface Tension with ANSYS CFX". In this paper, they conduct a simulation of dynamic capillary rise based on an experiment conducted by Zhmud, et al 2000 ("Dynamics of Capillary Rise").

So, I want to do this in FLUENT and compare it to the experimental data in the same way as Svihla & Xu. In their simulation, they create a wedge domain since CFX can't really do actual 2D simulations. So I thought I'd go straight 2D since FLUENT can do it. I've attached a picture of the 2D domain I made in the ANSYS Workbench. I created two surfaces from two separate sketches (and froze each one so they wouldn't merge). This is the only way I could think of to create the walls of the capillary tube and the larger beaker that it is placed in.

Here's my problem. I mesh the two surfaces using separate uniform quad methods (the mesh for the capillary tube is much smaller in order to resolve the surface of the liquid) and designate named selections (axes, inlet & outlet for capillary tube) - pic attached. When I import the mesh to FLUENT and do a mesh check I get an error that I cannot make out. FLUENT says that most of my cells in my mesh have only wall faces. First, I have no idea what this means. I looked at the location of the cells that FLUENT designated as having this problem and I can't figure out anything that they all have in common. Another user who had encountered this same mesh check error suggested converting the domain to polyhedra, but I found that this is not possible in a 2D simulation.

Is this not the right way to go about setting up this problem?? I feel like I am missing something really fundamental here but since I am relying solely on ANSYS & FLUENT documentation and, well, this forum I feel like I am losing the forest for the trees! Any ideas or advice? I'm happy to provide more info if necessary.

cp703 February 27, 2013 16:58

1 Attachment(s)
Hmm...doesn't look like my picture attached...

diamondx February 28, 2013 10:38

did you use icem cfd for meshing or did you go with ansys meshing

cp703 February 28, 2013 10:39


Originally Posted by diamondx (Post 410663)
did you use icem cfd for meshing or did you go with ansys meshing

I went with ANSYS meshing.

diamondx February 28, 2013 11:23

i can't really pinpoint the really, it can be from various sources. can you share via dropbox your project file, or your msh file.

cp703 March 1, 2013 12:36

Here is the project file! Sorry for the delay...wasn't at my desktop at all yesterday!

diamondx March 1, 2013 12:39

the wbpj file is not enough, it goes with a folder with the same name... please look for it. that folder contains the necessary files like the mesh file and the geometry file. add them both to one archive and share it. thanks

cp703 March 1, 2013 12:46

Of course. Silly me. I put the .wbpj file and the folder with the other files in a compressed folder here:

Does that work?

diamondx March 1, 2013 16:55

i have some question, please refer to the picture below:

i guess you want the red boundary to be wall ?
The blue boundary to be blue ?
How about the black ? i guess it will be interior ??

cp703 March 1, 2013 18:53

Right. Red to be wall. Blue to be axis. Black is the opening of the capillary to the region of the interior of the beaker.

diamondx March 4, 2013 11:16

Sorry for being late. I could mesh it with icem cdf i don't know you you are familiar with it.

here is the msh file:

cp703 March 22, 2013 11:23

Sorry to open this thread back up...

I guess FLUENT doesn't like axisymmetric simulations where the axis isn't on the x-axis so I need reorient the mesh. I was trying to re-make the geometry/mesh that you posted, diamondx, in the ANSYS DesignModeler and Mesh with the axis on the x-axis. I seem to have a problem making the geometry appropriately. DesignModeler will let me make the capillary wall that extends into the interior of the domain, but after the surface is created I am no longer allowed to touch it (i.e. make a named selection out of it to designate it as a wall). I don't think I have access to ICEM at this point so I'll have to stick with ANSYS meshing for now. The ANSYS meshing seems to work totally fine for me otherwise so it seems like I might just be setting up the geometry incorrectly. I have also tried to make two separate surfaces, but I can't get them to talk to each other in FLUENT (and by that I mean fluid won't flow between the two).

This really doesn't seem like it should be that difficult! I've been looking for a solution to this for days on the forums and online in general and haven't found any (solved) problem that's similar enough to be applicable! I'm pulling my hair out!

diamondx March 22, 2013 18:02

hy there,
I'm not good with ansys meshing. this is what i suggest:
- send me back the mesh, i can easily apply a rotate operation to make the axis along x. no need to change anything.
-Go take your old geometry in designmodeler, you can rotate it via body operation -> Rotate. and choose the setting you want. the mesh will be updated automatically in ansys meshing

cp703 March 22, 2013 21:11

Hi Ali,

I have done that so I will go ahead and PM you the geometry as before. Maybe I'll also hear from someone who has encountered this in ANSYS Meshing so I can know for the future.

Thank you so much for your help!

All times are GMT -4. The time now is 10:54.