CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ANSYS Meshing] ANSYS 14.0 Workbench ICEM CFD Interactive meshing (

Bill Tuer May 27, 2013 11:05

ANSYS 14.0 Workbench ICEM CFD Interactive meshing

I'm trying to do a similar meshing like in this tutorial video:

At the beginning in ICEM CFD I want to replace the initial block by a new one - so I did it like in the tutorial and closed the blocking, generate a new initial block with the name of the deleted block and associate the edges.
If I generate the pre-mesh, convert it to unstructed mesh and go back to the workbench meshing I get two errors with a long unspecific text which meens in rough translation that some elements can't assigned to some objects...
Nevertheless the mesh is correctly shown but can't used.
In both cases I used the default values and changed nothing from one try to the other.

So I tried a lot of things and come to the following:
- if I use the automatic generated block everything is fine
- if I replace the initial block with a new one the errors occur

It seems that the automatic generated block is 2D because I only get a mesh on the surface of my geometry but I need a 3D mesh.
(I also tried to replace it by a new 2D block - I doesn't work, too)

So what can be the reason and how can I get it working?

I hope somebody can help me...

Okay the automatic generated block is 3D swept block. I tried to change it to mapped but it doesn't worked because the "corners are not clear".

mvoss May 29, 2013 11:49

did you associate ALL points and lines in your blocking?

Bill Tuer May 29, 2013 13:17

Yes, but I think thats the point.
I tried several things, e.g. just to disassociate one vertice or one edge - and then the back transfer failed.
But I didn't get it with a new block working, either. I split the block several times and associate all vertices and all edges to points and curves.

The inital block is a single one (swept) and all vertices and edges of this one are associated to the geometry. But I want to have several splitted blocks to get a straight mesh.

mvoss May 30, 2013 03:51

i would guess it is because of the changed blocktype.
are u running 14.5? There is a new ICEM container which i am using all the time, and a tcl/tk script and everything works quite well (updating geometry, automatic hex meshing with different blocking, and mesh refinement e.g.)

Bill Tuer May 30, 2013 10:51

No, as I mentioned in the title I am running 14.0 and I don't have the possibility to use 14.5.
My intention was to use the interacitve ICEM meshing inside a Workbench remeshing script. But in the meantime I have to notice that this doesn't work. If I start the meshing process the recording stops with the hint that a batch process is starting which can't recorded.

So it seem I have to find another way to realize my project...

Maybe I start a new thread on this topic - I want to remesh in ICEM with an updated geometry after a non uniform deformation on a boundary (CFX) - or has someone a tutorial or good source as a starting point for me?

All times are GMT -4. The time now is 00:33.