CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ICEM] Surface/Volume orientation errors growing prism layers (

jlichtwa August 20, 2009 13:42

Surface/Volume orientation errors growing prism layers

I have a fairly complex geometry that I am growing prism layers on and I am having trouble fixing the surface orientation errors that are a result of ICEM growing the prisms into adjoining volumes. The error that results is

cells near 0.399948 -0.027646 -1.093522 occupy the same volume
cells 23690080 and 311981
face node numbers 1139962 5344708 5344709
opposite vertices 5344710 4805721
cells near 0.399877 -0.027849 -1.093494 occupy the same volume
cells 311981 and 4224035
face node numbers 4805720 4805721 5344709
opposite vertices 1139962 4805719
faces are missoriented

The problem areas all occur where two different sized tet regions transition to each other, just in a new place every run. I have tried to change the growth ratio and the number of layers to try and get better transition between the different size tet's but ICEM never seems to run without returning these errors.

Thanks for any help or suggestions.

PSYMN August 21, 2009 09:04

Bugs Happen...
Yes, this is some kind of annoying bug that showed up at 11 or 12 (I am constantly a release ahead and sometimes forget when)... It is fixed in 12.1 due out in Nov 2009...

Anyway, in the mean time, if you get this issue and you don't think it is your fault (your geometry is not crazy), then go into the Prism settings, down to the bottom under Advanced prism parameters, and turn on "Use Prism10"...

Then run it again.

Sorry for the hassle.

Jasmine March 13, 2010 03:00

I am using Ansys V12.0.1. Now I encounter the same problem.
However, i try to change Prism settings to prism 10, it gives me license error problem? Why is that please?

Flexlm error: can't get config for feature prism (ICEM CFD Engineering): Cannot find license file
The license files (or server network addresses) attempted are
listed below. Use LM_LICENSE_FILE to use a different license file,
or contact your software provider for a license file.
Feature: prism
Filename: /usr/ansys_inc/v120/icemcfd/linux64_amd/lic/license.dat
License path: /usr/ansys_inc/v120/icemcfd/linux64_amd/lic/license.dat
FLEXlm error: -1,359. System Error: 2 "No such file or directory"
For further information, refer to the FLEXlm End User Manual,
available at "".
can't open license file
License path: /usr/ansys_inc/v120/icemcfd/linux64_amd/lic/license.dat
ansys license 282 is not available in the license file
failed to get ansys license 282: return code -5,
Product: ANSYS ICEM CFD Prism Mesher (feature 'aiprism')
Checkout failed for the above product.
FLEXlm error message:

PSYMN March 13, 2010 22:31

Do you have a license?
If you check that location, do you find the license file? Does it have the "aiprism" feature in it?

If you check the ANSYS Inc (or FlexLM) license manager, does it show your license as running?

Sorry, I just thought I would get the obvious things out of the way first... Not sure why else it wouldn't work.

Perhaps you are on academic licensing and this older (version 10) key, doesn't know to work with the newer academic licensing? (I don't know that it doesn't but since it is a Beta (or more like Zeta) feature, they might not have tested it with every possible licensing configuration.)

If that is the case, at least the proper fix is now released.


rwryne April 27, 2010 15:03


Sorry to bring up an old thread, but I have a quick question about these volume orientation errors.

Are they a huge problem? I am getting (12,000 of them!) them during the split prism layer part of the process. As in: I generate a single layer prism, and do the check with no problems. I then split it into say 5 layers and the problem shows up.

ICEM 12.1

PSYMN April 27, 2010 18:20

It depends...
It depends...

Take a look at them...

Do they look fine, but just the numbering is wrong? If so, they are just a node numbering problem and easily fixed.

Are they twisted or passing thru themselves or other elements? If so, then you have a problem. Contact tech support as I will be traveling soon.

alquimista March 13, 2012 07:30

I have the same problem with ICEM 13.0 (Build date: October 05 2010). How can I fix it?

PSYMN March 13, 2012 15:27

Your problem may be a bit different. More details would help.

alquimista March 13, 2012 19:26

2 Attachment(s)
I'm meshing a "complex" geometry using the next method (following some advices in this forum):
  • Volume Mesh => Mesh Method (Robust Octree)
  • Prism Mesh
  • Convert Tetra to Hexa (12 tetra to 1 hexa)
In step 2 I get the error mentioned above (attached in file prism_error.txt). Even with the error I can use the mesh to solve my case in CFX without apparent problems, but I wanna try to clear this errors because I get also errors using the output solver Fluent_V6 (attached in file fluent_V6_errors.txt). Altough I don't know if it could be related.

Thanks in advanced. Your tips in other post were helpful for me.

PD: I need to use Fluent_V6 for export the mesh to other CFD software, in that case OpenFOAM

alquimista April 1, 2012 11:03

I also solved it using Prism V10 (libstdc 33 was required in OpenSUSE 11.3)

sidharath August 31, 2015 09:57

Same problem in ICEM CFD 15.0
Hi Simon, I am sorry to revive such an old thread but unfortunately i am facing the similar kind of problem.

I am modeling compressor stage and using a fairly standard process in ICEM 15.0.
Geometry clean up --> surface mesh using octree-->Delaunay for vol --> mesh inspection and merging/moving nodes as per need --> make consistent and flood fill --> check mesh --> prism layer.

In my earlier models this approach worked just fine. I am doing mesh independence study now and this problem has surfaced. I get below pasted errors and then i can't export the mesh in CFX (gives the error: not able to generate the valid mesh elements).

cells near -0.029893 -0.019099 -0.024232 occupy the same volume
cells 15692 and 44060
face node numbers 2306856 8236784 8615586
opposite vertices 4114464 4114464
cells near -0.038707 -0.022714 0.013155 occupy the same volume
cells 1245012 and 3603
face node numbers 7702011 7702012 8226339
opposite vertices 7702010 1437046
cells near -0.038904 -0.022690 0.013163 occupy the same volume
cells 3603 and 4871369
face node numbers 1437046 7702011 7702012
opposite vertices 8226340 7702010
cells near -0.038904 -0.022690 0.013163 occupy the same volume
cells 3603 and 99903
face node numbers 1437046 7702011 8226339
opposite vertices 7702012 8226340
cells near -0.038904 -0.022690 0.013163 occupy the same volume
cells 81795 and 3603
face node numbers 1437046 7702012 8226340
opposite vertices 2761432 8226339
cells near -0.038904 -0.022690 0.013163 occupy the same volume
cells 3603 and 99903
face node numbers 1437046 8226339 8226340
opposite vertices 7702011 7702011
cells near -0.029957 -0.018940 -0.024029 occupy the same volume
cells 50299 and 15692
face node numbers 2149332 2306856 4114464
opposite vertices 8615586 8615586
cells near -0.029957 -0.018940 -0.024029 occupy the same volume
22 more messages - not printed
All messages saved to file ERROR_LOG6.tmp"

Before generating the prims, default check mesh shows no errors (except multiple edges, which are intended in model).
I was wondering if you could share your inputs on what might be wrong with model.
How can i see these element number mentioned in the error log in ICEM screen and also if you could give any pointers on the direction what might mitigate this situation would be highly appreciated.

Thank you and I look forward to your response.

Far August 31, 2015 09:58


Can you attach tin file?


sidharath August 31, 2015 10:36


Originally Posted by Far (Post 561792)

Can you attach tin file?


.tin file as in the geometry file ?

Far September 1, 2015 02:26


sidharath September 1, 2015 07:05


Originally Posted by Far (Post 561882)

hi FAR,

I am afraid i can't share the .tin file due to IPR constraints. I would very much appreciate your inputs on the problem I am facing in prism cells generation.
Thank you.

All times are GMT -4. The time now is 04:09.