CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ICEM] Coarse mesh nearer to curves (

jsm September 9, 2009 07:24

Coarse mesh nearer to curves

In ICEM, I generated the tri surface mesh. But surface mesh is not uniform throughout the surfaces. In curves, the mesh is coarse. I tried one more time with following changes. In curve mesh setup, I selected all curves and applied maximum size is zero. But I am getting same mesh (coarse mesh nearer to curves). How to avoid this?

PSYMN September 10, 2009 13:25

More info please...
ICEM CFD has several methods for generating surface mesh... What are you using?

Can you also show a screen shot for us to better see what is happening.


jsm September 11, 2009 00:21

3 Attachment(s)
Hi Simon Pereira,

Thanks for your reply. My actual geometry is bigger and complex one. I explain my issue with simple cube geometry. There also I am getting same type of mesh.

Geometry is one unit length in all three directions. For top surface of cube, I gave 0.01 mesh size (refined mesh size) and for remaining 5 surfaces, I gave 0.05 mesh size (coarse mesh). I am meshing the geometry with patch dependent meshing option. I got this kind of mesh.

I can get uniform mesh while meshing the top surface first and remaining surfaces after that. Surely it will work. However for complex geometries, it is difficult. Is it possible to mesh in single stroke.

PSYMN September 11, 2009 09:17

Curve sizing is the key
Ok, you are using the patch dependent mesher (AKA ICEM CFD “QUAD” mesher). This is a recursive loop algorithm. By default, it starts from a loop at the perimeter of the surfaces and relies on the curve sizing. In your case, 2 of the curves are set with larger sizes and 2 are set with finer sizes. If you want the whole top to be fine, you should set the 4 curves all to finer sizes. Under the mesh tab, you will find an option to set sizes on curves. In the model tree, you can right click on curves to “display curve sizes”.

By default, it uses only curve sizing. If you wanted to use the surface mesh sizes, either to coarsen or refine relative to the perimeter (the curve sizes are still needed), then go to Global Mesh setup => Shell Meshing Parameters. With the “Section” set to “Patch Dependent”, turn on “Adapt Mesh interior”. The rate of transition is controlled by the ratio on the curves.

You may also want to try some other algorithms, like our Patch Independent Tetra. You can select which algorithm is the default by changing the “Section” on that same menu; Global Mesh setup => Shell Meshing Parameters

jsm September 15, 2009 03:07

3 Attachment(s)
Hi Simon Pereira,

Sorry for the delayed response. I am unable to see your reply. I gave mesh size for all curves and enabled the "adapt mesh interior" option. Once again I did the patch dependent surface mesh. But mesh size transition from the curves is not smooth. I tried octree volume mesh instead of surface meshing. I think that the octree volume mesh gives really good surface mesh with smooth transition than patch dependent surface mesh. I could not understand the reason. Further any settings are required for patch dependent surface meshing?

I can do volume mesh by delaunay algorithm from octree surface mesh and finish the meshing for this geometry. Just I want to explore further.

Expecting your suggestions...

PSYMN September 15, 2009 11:18

Help has some answers...
Under the help menu it does explain some more about how to control this patch dependent option... I put a wink;) next to the key part. I think I had mentioned the ratio on the curves, but actually, it is the ratio on the surfaces...

Adapt mesh interior Uses the surface sizes to coarsen the mesh internally. For example, if curve size is set to 1, and surface size to 10, then the mesh will start with a mesh size of 1 on the curves, but transition to 10 in the middle of the surface. This is more effective on larger surfaces where the element reduction is more dramatic.

The default growth rate for the transition to the surface max size is 1.5. This growth rate can be adjusted by setting the surface Height Ratio to between 1.0 and 3.;) Sizes below 1.0 are inverted (i.e., 0.667 = 1.5). Sizes above 3 are ignored and the default is used. If this option is enabled, Force Mapping is disabled on surfaces whose maximum size setting exceeds its perimeter curve sizes by a factor of 2 or more.
The difference in the transition rate is shown in Figure 18: Example of Adapt Mesh Interior option:
Figure 18: Example of Adapt Mesh Interior option
Adapt Mesh Interior option disabled
Adapt Mesh Interior option enabled
Default Surface Height Ratio = 1.5
Adapt Mesh Interior option enabled
Surface Height Ratio = 3
The Max Element size specified in the General Parameters takes precedence over this value.

For All Quad, Quad Dominant, and Quad with one Tri mesh, the Force Mapping option has priority over this option. To apply the Adapt mesh interior option to these types of mesh, set the Force Mapping value to 0.

jsm September 16, 2009 00:56

Hi Simon Pereira,

Thanks for your kind reply. Now I understood the patch dependent mesh settings. :)

I have further few questions to you. When I am using ICEM CFD, I came across these questions. Please clarify this.

1. While doing volume mesh smoothing (with default smooth settings), mesh in some geometry parts (where quality is not good like very narrow parts) is altered to improve the mesh quality. But mesh is not obeying the geometry. How to avoid this?

2. There is any relation between geometry topology tolerance value and edge criterion value (octree mesh parameter)? How they affect each other?

3. In prism mesh generation, is it possible to get non conformal interface between prism and tetra elements to avoid pyramid generation?

Kindly give your suggestions.

PSYMN September 16, 2009 11:43

Hello again,

1)An image would help. Turn on the display option to show nodes as dots (right click on shells). If a feature has curves, then the mesh generated on those curves should have green curve associated nodes. Unless you have turned on the “violate geometry” option of the smoother, it should respect these green (curve) and red (point) nodes. Making sure your mesh is associated with these features is the first thing to check. You may also want to make sure you don’t have the smoother options for “violate geometry” or “merge” or “coarsen” on.

2)Nope, Geometry tolerance has to do with removing those feature curves during build topology, so if you have two surfaces near each other, but separated by greater than the geometry tolerance, you will get two yellow curves (nothing happens). However, if they are within the geometry tolerance, it will remove one of the curves and make sure the remaining curve is associated with both adjacent surfaces. Then when mesh is generated, nodes formed in the area will follow the curve to capture the feature. The nodes will be green (if the dots display option is active), and the smoother will be constrained to move them only along the curves. On the other hand, edge criterion determines if a node should be moved or if an edge should be split based on the location of the geometry relative to the node locations. The number is a percentage of edge length, so 0.2 means that if the node is within 20% of the edge length of the surface, curve or point, move to the entity. If it is more than 20% from the entity, spit the edge in half and run the query again. Setting this to a smaller percentage results in more refinement to capture features. Tri tolerance is a third tolerance, but it has to do with behind the scenes conversion of the bspline to facets, both for display and Octree node projection.

3)Nope, that sort of non conformal prism mesh is not available in ICEM CFD. It is actually not supported by very many solvers. It is supported by Fluent, and so you can generate that sort of mesh using TGRID prism. If you want to avoid prism generation with ICEM CFD, there are many things you can do… Ask that as a separate thread and I will try to find a ppt to post with optimal settings.


jsm September 17, 2009 07:07


Thanks a lot for your suggestions.:)

I will open new thread for prism generation (non conformal interface).

All times are GMT -4. The time now is 12:29.