CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ICEM] Scaling Mesh from Millimetres to Metres (

Josh July 8, 2010 17:58

Scaling Mesh from Millimetres to Metres
Hi all -

I accidentally created my ICEM mesh in mm units when it should have been in m units. Once I import it into CFX-Pre, I know I can scale the mesh by 1000 to convert it to m, but I want to know if I can scale the mesh in ICEM from mm to m.

Thanks for your time!

Josh July 8, 2010 18:14


I want to extrude the pre-mesh. To do this, I went to Blocking > Transform Block > Scale Blocks and scaled by a factor of 1000. However, when I did this, my pre-mesh was not scale properly - it looks very different from the unscaled pre-mesh. I also scaled the geometry by 1000. Any ideas why the pre-mesh wouldn't scale properly?

PSYMN July 9, 2010 09:40

Scale blocking, not edge params...
In ICEM CFD Hexa, if you scale down your geometry and you scale down your blocking by the same amount, the number of nodes on all the edges should be the same (don't change your edge distributions or use the refine/coarsen option, just scale the blocking using the transform options.)

Maybe a pic of the problem and a bit more info about how you "Scaled Premesh" would help.

Josh July 9, 2010 12:36

Strange. I could have sworn I did exactly what you said (scaled geometry x1000 for x, y, z, then scaled blocking x1000 for x, y, z). I made another attempt using the same method and this time it went fine!

Perhaps the problem lies within what I selected when I chose the geometry/blocks to be scaled (the first time around). I have this habit of using the "select all appropriate visible objects" button (the one with the glasses icon) to select "everything" I want to affect. However, some of the objects are hidden, i.e. I have their visibilities turned off in the model tree. Thus, all "visible" objects may be an inappropriate choice as not everything is visible. For example, in terms of the geometry, I usually only display the curves (thus, the points and surfaces aren't visible and, therefore wouldn't be selected). Is this the case?

This time around, I made sure all the objects were visible.

PSYMN July 9, 2010 13:59

Sure, or you could use the option to select "all" (hot key "a"), and then you wouldn't need to display everything...


Josh July 9, 2010 14:15

I know about that hotkey, though it doesn't seem to work for me. Do you physically type it in the box where the selected objects appear, or do you simply hit "a" when ICEM requests for you to choose the desired objects?

PSYMN July 9, 2010 17:07

Hotkeys only work when the cursor is in the display window.

They are tab and context sensitive.

There are hotkey maps and more info in the help. (search for "hotkeys") Many people print out the maps and post them by their computers. Hotkeys can really speed up your use of the software and they are especially useful for mesh or block editing.

Best regards,


Josh July 9, 2010 17:09

Thanks, Simon!

Sujit April 28, 2014 10:30

Scale Mesh in z axis only
Hii I want to scale mesh in z axis only from mm to micro meter???

if i do while exporting then what is the problem???

it gives only problems to periodic parts..

All times are GMT -4. The time now is 13:34.