CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   unable to attach the geometry file (

artemis64s September 22, 2010 08:36

unable to attach the geometry file
I have created a 3D geometry in Design Modeler, then I extracted the data as .agdp. now I am going to mesh the geometry but it fails to load the file in mesh system! the error is :
''unable to attach the geometry file''
and the meshing window is gone then,
I also extracted the geometry to .igs and also to .stp but still the same problem... :(

can anyone help me in that please?

PSYMN October 5, 2010 19:32

The schematic can transfer the files for you...
Are you using ANSYS Meshing? Why not just connect the meshing system to the DM system on the project page schematic (just drag and drop)... That is the beauty of WorkBench...

If I am misunderstanding, please add some more details.

yus310 March 10, 2011 15:30

I'm having the same problem for ansys fluent 12.0. I have constructed my geometry and then when I try to update my project, it says "unable to load geometry into mesh cell... ", equally if I try to open up the mesh option, ansys fluent doesn't recognize my geometry and closes out.

Any suggestions to remedy this?


PSYMN March 11, 2011 11:44

No I am not sure where you went wrong, but it should work so I suggest you go back into DM and look at your model again... Is it corrupted in some way? Is it properly part of the project (does clicking on the geometry field open the right file in DM)? Can you post a screen shot of your project schematic so I can see how you hooked it up?

yus310 March 11, 2011 11:50

My geometry is linked to the project schematic, and when i open up the geometry in project schematic, I get the geometry (just a tube). The only thing is the mesh won't recognize the geometry. When I upload other people's geometry, still the mesh won't recognize the geometry. The geometry is 2-D, it just a rectangle turned into a surface for 2-D fluid flow analysis.
The geometry has a check in the project schematic and the mesh has a recycling like symbol.

Some suggest using CAD Configuration 12.1, etc. But I don't know if it is a licensing issue, or something else.


PSYMN March 12, 2011 18:48

I suggest you start over... Clearly something has gone wrong.

Just start over, create a new rectangle, make sure you create a surface from the sketch (did you do that?), then proceed to meshing and see what happens...

Thousands of customers do this everyday without any trouble.

sac March 12, 2011 20:24

Set the geometry type in the schematic to 2d?

Jackpot October 15, 2013 13:31

I have the same problem, 2D surface with a check in the DM but with a cross in the Mesh.

When I try to open the mesh it close suddenly and ansys show the error message "unable to attach to geometry file".

Anybody has some advice?

Thank you

Jackpot October 15, 2013 17:28


I have tried to solve the trouble asked before and finally the solution was on changing the 2D surface body from YZ to XY plane.

All times are GMT -4. The time now is 21:42.