CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ICEM] Bad elements in the narrow gap (

saisanthoshm88 January 21, 2011 14:06

Bad elements in the narrow gap
I was making a Tet mesh to a geometry which had a very narrow gap between two surfaces , the volume elements between the two surfaces were too worst.

It was as if the elements got crushed in between the surfaces

To resolve the problem i've tried the 'Define thin cuts' option but that didn't help.

Can some one please suggest on overcoming the problem.

PSYMN January 21, 2011 14:54

Thin regions and the OCTREE Mesher.
It is the Octree subdivision process that has trouble with these thin regions. Basically, the background grid is not sufficiently refined to capture the feature. There is a second refinement that happens during cut in that you could also improve. So, you can either worth with the process, or use a different process.

Octree Options...

1) Reorient the model... (If your thin cut aligns with a Cartesian plane, it is easier for octree to refine and capture it.)

2) Set a smaller mesh size (Initial background grid improvement)

3) Set cells in gap (secondary background grid improvement)

4) Set "Thin cuts" (helps during the cut in phase by not allowing nodes from one side to be connected by a surface element to nodes on the other side... This tries to prevent jumping, but may fail if the mesh is too coarse or if the two sides ever share a single node.)

5) Reduce the edge criterion (helps during the "cut-in" phase of octree that decides if an element should be refined or the node moved to capture a surface. The default is 0.2, change this to 0.02 and see the difference)

Other Options...

6) Separate out that portion of the model and mesh it with a different method (such as ICEM CFD Hexa), then bring it back in and merge it with the rest of the model. This is often a very efficient method, but it depends on the model.

7) Try surface meshing the model and then use a bottom up method (such as delaunay with TGLib). Note, you still need some care to ensure that the mes size in the thin region won't be too coarse to give good quality tets across the narrow gap, but it can usually be much larger than for the octree method.

saisanthoshm88 January 24, 2011 11:43

Thanks for the help Simon, your suggestions worked. I've increased the mesh refinement in the problematic region slightly .The edge criterion value was also changed to 0.02 . The problem was then fixed.

I could indeed notice a decrease in the number of elements in the mesh when the edge criterion value was reduced to 0.02 from 0.2 so I understand that the nodes are moved to capture a surface and that the elements are not subdivided.

Then is it recommended to have a lower edge criterion value ( like 0.02) for meshing any geometry in general.

PSYMN January 24, 2011 16:37

Nope, the default is recommended for most geometries... We did try to set that lower but sometimes got complaints about over refinement when moving nodes would have been better...

saisanthoshm88 January 25, 2011 06:05

Well, my conception was that the extent of subdivision decreases with a decrease in the Edge criterion value. Please clarify upon,if it is misleading.

PSYMN January 25, 2011 13:31

Edge Criterion Explained...
1 Attachment(s)
Edge criterion looks at where the geometry is relative to the node as a percentage of edge length. If the node is within the edge criterion distance from the surface, it is moved. If it is not, then the edge is split (an new node is added, the mesh is locally refined), and the question is asked again.

so... Imagine a case where the surface falls 0.4 of the way across an element edge.

If edge criterion is set to the default of 0.2, the edge criterion is exceeded. Instead of projecting (moving) the nearest node to the surface, the edge is split and a new node is created. That new node is at the 0.5 mark, so there are two new edges. The one is completely inside the volume (no geometry intersect), the other one now intersects the geometry at about the 20 percent mark.

If it is actually a little less than 20%, the node will simply be moved to fit to the geometry... This is usually good. If it is a little more than 20%, the edge is split again and the question is asked again...

Your problem is that your mesh size is large relative to the gap, so moving the node only moves it to the nearest of the two surfaces. Some times it moves to one side, some times the other, but without enough refinement to be sure you are capturing both sides... To much rounding, not enough refinement. Instead of moving the nodes, you want it to keep refining. Perhaps when it does that, instead of finding that one side has a surface and the other doesn't, it will find that edges on both sides of the new node have a surface, and then you start to get somewhere...

If you refine the edge criterion down to 0.01 (instead of the 0.2 default), you are forcing more refinement and less node movement. It will better capture that thin feature.

I have attached a slide from my advanced user training...

saisanthoshm88 January 25, 2011 14:22

Thanks a lot for such detailed description of the option Simon

All times are GMT -4. The time now is 23:33.