CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   TG_Mesh_Domain failed with error code 1 (

onionmon February 17, 2011 09:35

TG_Mesh_Domain failed with error code 1
Hi, I am having an error while meshing a 3D volume using the Tet/Hybrid on a TGrid.


TG_Mesh_Domain failed with error code 1
ERROR: Tetrahedral meshing has failed for volume myVolume. This is usually caused by problems in the face meshes. Check the skewnesses of your face meshes and make sure the face mesh sizes are not too large in areas of samll gaps

A search of previous posts do not help my cause.

I have cleaned my geometry to remove small edges and small areas and small angles. I have implemented size functions where applicable to mesh small areas. My face mesh check shows no elements with an equisize skew > 0.8. A check using geometry command button>check vertices; geometry command button>check edges; geometry command button>check faces; geometry command button>check volumes show 0 failures in the validity check for all different geometries.

What else am I doing wrong for this not to mesh??

Thanks ahead for your help!

onionmon February 19, 2011 05:23

OK, I solved my problem. Here is my follow up.

I discovered a vertex from one surface that was very close to another surface so that a 3D tet element was not able to be created during 3D meshing. The vertex closeness to a surface is shown in a rough diagram below.


|-----|    |-----|
|      |_._|      |

I solved the problem by zooming out so I can see my entire system. I noticed a white vertex (multi-edged vertices are purple) sitting by itself in the middle of a face. I created a geometry and boolean-subtracted it from my base geometry so that the vertex was removed. Then I was able to mesh.

All times are GMT -4. The time now is 04:48.