CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ICEM] icem mesh to CFX 12.1 (

atturh February 22, 2011 21:13

icem mesh to CFX 12.1
I am using Icem CFD 12.1 and need to transfer the mesh from icem to CFX 12.1 .

Somehow i dont seem to find the option as when i go to output> Output solver and choose Ansys CFX and later click on Write input it gives only the option for Cfx5. I was just wondering why isnt the CFX 12.1 option available . or am i doing something wrong.

PSYMN February 23, 2011 10:25

Yes, those version numbers can be concerning/confusing... I think you can just assume that the file format has not changed for a few years. CFX5 format will work for CFX12.1 or 13.0 or 14.0.

I heard the same complaint about Fluent, so for 14.0, we are pretty much just adding ANSYS Fluent to the list for show. In the background it uses the same output interface as the Fluent_6 output.

I will look into the GUI for CFX and perhaps implement a similar innovation. Maybe it should be a check box option for the older versions, but CFX5 and newer is just the default? I will think about it.

(Note, after taking a look, I think the CFX output form is fine... It clearly says "5.5 or later" and that is the default.)

atturh February 23, 2011 10:38

not working
hmm....that is weird , because when I tried taking the mesh from icem 12.1 to cfx 12.1, the icem mesh creates a ".cfx5" file, even though I specified I am using cfx pre 5.5 or greater. The input file for cfx 12.1 is ".cfx" . So when i import it to cfx -pre it says file not recognised. When i manually change the file type to .cfx from .cfx5 it still doesnt recognise.

I was trying it late night yesterday , will try it again today just to cross-check since you say it should work.

PSYMN February 23, 2011 12:06

OK, I will look into it and get back to you.

atturh February 23, 2011 14:57

i tried it again today morning, the same problem. it is not recognising the file in cfx pre 12.1 .

btw thanks for your quick replies :)

PSYMN February 24, 2011 12:48

Worked for me... Here is my process.
4 Attachment(s)
I just went thru the process (I guess it has been a while since I did any of this manually), and it seemed fine. Here are my steps.

1) Output from ICEM CFD in "5.5 or later". This creates the .cfx5 file extension.
Attachment 6632

2) Open CFX Pre and start a new case.
Attachment 6633

3) Import Mesh into the new case
Attachment 6634

4) Select the .cfx5 file... Make sure to set files of type to "ICEM CFD"... I guess that was probably the issue all along. Setting it to CFX Mesh won't work.
Attachment 6635

The file imported into CFX Pre without a problem.

Are we set with 4) now?

atturh February 24, 2011 15:33

thank you so much for method. i just realized I asked a pretty stupid question. i should have meddeled with it more.

What I did was, I went through the standalone mode and when i clicked CFX-pre it did not give me option to import ICEM Mesh file.The mistake i did was i did not open a new case and click import, i was doing it directly.

thank you again. i appreciate your help.

All times are GMT -4. The time now is 09:30.