CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   ICEM CFD: Import STL file error (

8leemichael August 26, 2011 12:55

ICEM CFD: Import STL file error
Hello all,
As the title states, I have a problem importing STL files with ICEM CFD. I select import geometry > stl and then select my file, but the error I receive is:

ANSYS ICEM CFD STL2DF 13.0 compiled on 10/5/2010
running on Windows (64 bit version)
(c) Copyright 1993 - 2010 Ansys Inc.
domain error: error opening file ./tmpdomain0.uns : Permission denied
df_open:: Permission denied
Error: no file was created from file.stl

I downloaded other STL files from the web and tried to import those too, but have the same error. Is this a licensing issue or am I doing something wrong? I am using ANSYS ICEM CFD 13.0. Thanks for all your guys' help and time.

- Michael

Nils_H August 31, 2011 12:22

Well, to me this sounds like a liscence error. Were you able to import the stl file as mesh (import mesh --> from stl)? If that is not working and the original data is not blocked or unable to be open in general (corrupt data), I would say this is a liscence issue. What might help to get this geometry loaded into ICEM would be to open it somewhere else (CAD tool or else) and import surfaces as .step or .iges files into ICEM via reverse engineering. Rhino3D does that as free tool (trial) as well as Geomagic and some others of course. Hope that helped.

wiedangel October 22, 2012 08:26


did you solve this problem?

I may have a solution for you.


meleni December 5, 2012 10:55

I actually have the same problem with the ANSYS 12. I did not have it when I had icem cfd installed on windows xp, but now that I installed it on Win 7, I receive this message when I try to open an stl file (either as geometry or mesh). Do you (wiedangel) have a solution?
Thanks in advance

rezendervp October 22, 2015 22:46

License error in ICEM indicates which module or feature is not present in the license file. This is a access error. There are a temp file during the translation in ICEM import. THis tmep is writen in C:/ what generally is not permitted to write in it on Windows UAC directives. Because " permission denied" message. Change your user type, or execute ICEM as Administrator. The STL feature will work. I hope :)

All times are GMT -4. The time now is 22:30.