CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ICEM] Hex-tet merge (

doodek October 29, 2011 05:16

Hex-tet merge
I have two blocks (cubes) adjoin one surface. Surface from tetra cube are in another part then surface from hexa cube. Geometry is only in hexa volume, because tet part is imported from separate file. Next, I use 'repair mesh -> associate with geom'. This way I associate tri surface elements to geometry. Tetra elements (2D) are moved to part with surface quad elements from hexa volume. When I want to merge two meshes surface (with both quad and tri elements in one part) is selected and hex volume as frozen volume.

Unfortunately there are many multiple edges (shown above). Maybe do you know how to deal with it?

Best regards,

PSYMN November 1, 2011 16:27

Not a problem...
Multiple edges are only listed under "possible problems".

I would expect to see them around the perimeter after a merge. It just means that the elements along that edge are connected...

If you want the interface surface to remain (such as for CHT), then you are fine. Proceed to solver.

If you wanted the flow to be open between the hexa and tetra regions, you just need to delete the quads in that interface part...

Go to Edit Mesh and delete elements. For selecting the elements, use the select by part option from the tool bar and select the interface part...

doodek November 2, 2011 08:16

Yes, I want to calculate flow between hexa and tetra region, so this region should be open. If I delete quad elements on interface surface, the problem with 'missing internal faces' appears...

PSYMN November 2, 2011 09:56

Missing internal faces means that volume elements of different fluids are not properly separated by an interface (of shell elements). Your solver will want shells between elements of different zones.

If it is really one fluid, then just put elements on both sides into the same volume part.

Find out what the two parts are named. Lets say it was "FLUID" and "FLUID2".

In the model tree, right click on the one of them, "FLUID" and select "Add to Part". Then using the selection tool bar (pops up on the top right side of the display window), make sure it is in mesh selection mode (last toggle on the bar) and then select the option for "Select items by Part". When the part selection menu pops up, select FLUID2 and apply...

Now all your volume mesh is in one part and you won't get the uncovered faces error.

Another way to do this would be to create a new material (call it what ever you want), then when it asks you to select entities, toggle the selection toolbar to mesh selection mode and hit the option for select all volume elements... This will put all the volume elements into that one part and solve the problem that way. (Obviously don't do this if you have some volume elements that belong in another fluid or solid region).

doodek November 2, 2011 10:09

It works. Thanks a lot PSYMN.

All times are GMT -4. The time now is 02:52.