CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ANSYS Meshing] "Multibody Part" doesn't apply to Fluent? (

J_Alex December 7, 2011 13:00

"Multibody Part" doesn't apply to Fluent?
Hey everyone,

I'm having some problems with ANSYS Meshing Tool in WB - well, at least I think that is what the problem is based on.

Generally, I'm trying to simulate a combination of internal and external flows (quite complex geometry) in FLUENT.
My fluid domain consists of several fluid bodies (12 solids all in all) which should all share faces with the adjacent cell zones so that i don't need to define interfaces manually in Fluent afterwards.
Some of the bodies shall be implemented as porous zones and I would like to include a FAN-BC into the model in FLUENT.

I simplyfied my geometry in CATIA V5 and imported the bodies into Design Modeler via iges-files.
Although I included all of the bodies in one single part and the overall shared topology tool seems to work - Fluent doesn't connect the cell zones and decides to create walls where the cell zones meet.

How can I change that? Is that a problem in Design Modeler, Meshing or Fluent?

As i don't know how to approach that problem in Ansys Meshing I tried I already tried a couple of other things:
  • Via the "Fuse Faces" tool in FLUENT I create some bigger holes in my desired contact area as several faces of my mesh seem to be missing then - although the mesh of the two cell zones seem to be identical at that very face
  • When changing the WALLs to INTERFACEs via Named Selections in Ansys Meshing and coupling them in FLUENT I don't know how to create a FAN boundary condition
Any ideas? I would appreciate your help very much!


jsm December 12, 2011 10:04


From your message, I think that you got non conformal mesh between bodies.
You need to create part to get the conformal mesh.

To create the part, select all bodies in tree, right click to get the form new part option.

Update the mesh in ansys meshing. You will get conformal mesh.

J_Alex December 12, 2011 10:36

Hi jsm,

thank you for your reply but in the meantime I have resolved the problem somehow.

Stangely, it didn't have to do anything with creating a multibody part (which i have done in that case but without any success) - but with the way I created my fluid domain in general.
First, I created one single fluid domain which I then split up into subdomains via boolean operations (substract imported "internal" fluid domains) - and somehow Ansys Meshing didn't really like that.
When i tried it the second time, I first imported my "internal" fluid domain and applied an enclosure with a self-defined geometry around it as my "external" flow domain.

Everything worked out like that but i still don't understand why it didn't work the first time.



mjthomp3 June 18, 2014 16:15

I have the same problem but your solution doesn't fix it for me.....

All times are GMT -4. The time now is 02:20.