CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ICEM] Fluent skips parts i create in icem (

diamondx April 16, 2012 14:04

Fluent skips parts i create in icem
1 Attachment(s)
hello everyone,
I've modeled and meshed my air intake. I'm planning to plot an xy for the static pressure for the cowl lip and the ramp lip -see pictures below-. to make it easy in the post-processing this is what i did:
create part > select the curve that represent the cowl , named it.
did same thing for the lower curve (lip)
assign them boundaries as wall.
But Fluent can't recognize them, i missing something here, may be i had to associate edges with those curve i went back to icem i did it but still after the export those name doesn't appear in fluent. How i can do that ? thanks in advance

Far April 16, 2012 14:06


diamondx April 16, 2012 14:07

yes the inside was created with hexa mesh

Far April 16, 2012 14:13

Then you need separate block for each part. Just creating parts does not output the boundary.

diamondx April 16, 2012 14:45

2 Attachment(s)
Thanks Far for your reply,
i try what you did, i actually erased everything and initialized a new block with same dimension as those curve, association is done. but still doesn't show up. i got you another screenshot with the final result i wanna achieve.

diamondx April 16, 2012 15:00

above i noticed that they appear in the mesh display options under surfaces but not in the boundary conditions. That's fine for me since i just want to use them for plotting. and thanks for your patience

PSYMN April 17, 2012 09:05

You are doing something wrong, but have not given enough clues yet.

Bocos (boundary conditions) apply to shell elements. If you have shell elements in a part, they are visible in Fluent. Since you don't see them in Fluent, i am guessing that you don't have them in your ICEM CFD UNS file... So how did that happen?

1) Have you converted your premesh to uns mesh? Here is a test, check "info => mesh info" It should give you a list of how many elements you have in each part. Do you see your parts on that list? Are they listed only as quad-4 elements (no Hexa-8s)

2) Maybe your mesh on screen is perfectly correct with parts, etc. But the Fluent output executable works off a saved version of the mesh. Could it be that you are pointing to an earlier saved file that does not have these shell mesh parts?

Those are my first 2 guesses.

diamondx April 17, 2012 13:44

thanks for you help simon,
i made a small video of the steps i perform so i can i get the ramp and cowl boundary to work. the example is applied on a small square box. i hope you guyz can track and locate my mistake. Thanks a lot

PSYMN April 17, 2012 13:59

Oh, you are looking for edges with a particular boco... Not sure about that. I will try to test later today and get back to you. I typically use surfaces for bocos, but not edges.

A couple other tips... When initializing geometry, you don't need to select all the entities. If you don't select any entities, it is as good as selecting all of them. If you only wanted to block a range of your model, you only need to select a couple entities that will give you the min max coordinates for that range...

Also, when associating edge to curve for something simple (one to one relationship between edges and curves), you can just use the auto associate button (last on the bottom row) and it will do it all for you.


diamondx April 17, 2012 14:06

Thank you so much simon. Yeah may be it is not possible with Icem. The mesh that i showed before that includes that feature was made with tgrid. may be that's why. Anyway Thanks a lot for you help and your tips

PSYMN April 17, 2012 14:09

Actually, I just had a quick moment and tested. I got what you got... No line elements (or point elements) available under Boundary Conditions.

I called a Fluent Expert (formerly a support manager) and he said...


No, boundary zones in 3D are faces/surfaces.
You don't have any other option. You can specify particle injections from a line/rake but that's pretty much it.
ICEM CFD lets you set bocos for these because it doesn't know that you are going to do a 3D (instead of 2D) analysis. Other 3D solvers may also allow you to set bocos on 2D elements. Fluent does not.

What are you trying to set? Maybe we can work it out a different way.

Best regards,


PSYMN April 17, 2012 14:11

I just saw your TGrid comment (we must have been posting at the same time).

I don't think it was possible with TGrid either (since this is a Fluent limitation), so not sure what you are referring to there either.

Best regards,


diamondx April 17, 2012 14:32

Well that curve doesn't have to be a boundary condition. i just want it to be separate so i can select it later for plotting --> After some iterations in Fluent i want to do a xy plot of the pressure on that part. as you can see in the picture below i'm wondering how it was made

Far April 17, 2012 14:43

As I know this is not possible, you have to create these lines for post processing in Fluent or CFD post or any third party post processing software.

diamondx April 17, 2012 14:48

ahh , May be you're right. Geeez :eek: i didn't think about that. May be these lines were created in fluent itself... i'll try to figure out how. i totally forgot, spent too much time trying to get it done in icem. thanks for the tips far.

All times are GMT -4. The time now is 01:13.