CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > ANSYS

How To Install Ansys On UBUNTU

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By Abhishek_784

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   March 30, 2013, 14:41
Default How To Install Ansys On UBUNTU
  #1
New Member
 
Hamed
Join Date: Feb 2013
Posts: 7
Rep Power: 10
siqma is on a distinguished road
Hello
I am new here.
Please Help me to install Ansys 14.5 on ubuntu 12.04
Who could Install and use ansys workbench ubuntu?Please Tell me step by step
THX
siqma is offline   Reply With Quote

Old   April 20, 2013, 10:31
Default
  #2
New Member
 
dklastiwka's Avatar
 
Derek Lastiwka
Join Date: Feb 2010
Location: Calgary, Alberta, Canada
Posts: 26
Rep Power: 13
dklastiwka is on a distinguished road
I do not believe ANSYS is commercially available for linux anymore.
__________________
Derek Lastiwka
Mechanical & Fluids Engineer
dlastiwka@graymattereng.com
Gray Matter Engineering Inc.
dklastiwka is offline   Reply With Quote

Old   April 20, 2013, 11:52
Default
  #3
New Member
 
Dmitry
Join Date: Jan 2012
Posts: 5
Rep Power: 11
dr-kart is on a distinguished road
Quote:
Originally Posted by siqma View Post
...use ansys workbench ubuntu...
it's not that simple as one may think. it's all about workbench implementation on linux.
imho best way to start WB on linux is:
1. To have nvidia card with proprietary driver installed
2. Do install on CentOS or Scientific linux. Since the (almost) official support by ansoft.

But you can give a try on ubuntu. And it'd be great if you post your experience after.
http://ubuntuforums.org/showthread.p...8#post11931248
dr-kart is offline   Reply With Quote

Old   October 23, 2018, 14:43
Default
  #4
New Member
 
Abhishek
Join Date: Aug 2018
Posts: 3
Blog Entries: 1
Rep Power: 5
Abhishek_784 is on a distinguished road
The required packages from the installation guide (for RedHat/CentOS) are:
libXp.x86_64
xorg-x11-fonts-cyrillic.noarch
xterm.x86_64
openmotif.x86_64
compat-libstdc++-33.x86_64
libstdc++.x86_64
libstdc++.i686
gcc-c++.x86_64
compat-libstdc++-33.i686
libstdc++-devel.x86_64
libstdc++-devel.i686
compat-gcc-34.x86_64
gtk2.i686
libXxf86vm.i686
libSM.i686
libXt.i686
xorg-x11-fonts-ISO8859-1-75dpi.noarch
glibc-2.12-1.166.el6_7.1 (or greater)

1. Therefore I installed:
Code:
sudo apt install xterm lsb csh ssh rpm xfonts-base xfonts-100dpi xfonts-100dpi-transcoded xfonts-75dpi xfonts-75dpi-transcoded xfonts-cyrillic libmotif-common mesa-utils libxm4 libxt6 libxext6 libxi6 libx11-6 libsm6 libice6 libxxf86vm1 libpng12-0 libpng16-16 libtiff5 gcc g++ libstdc++6 libstdc++5 libstdc++-5-dev

2. Install manually libXp (not included in the standard repo), you can find it at:
HTML Code:
https://pkgs.org/download/libxp6

3. Update the database with:
Code:
sudo updatedb

4. Locate the following libs and create soft links based on your system. I did as follows:
Code:
sudo ln -sf /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 /usr/lib/libGL.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 /usr/lib/libGL.so.1
sudo ln -sf /usr/lib/x86_64-linux-gnu/libGLU.so.1 /usr/lib/libGLU.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libXm.so.4 /usr/lib/libXm.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libXm.so.4 /usr/lib/libXm.so.3
sudo ln -sf /usr/lib/x86_64-linux-gnu/libXp.so.6 /usr/lib/libXp.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libXt.so.6 /usr/lib/libXt.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libXext.so.6 /usr/lib/libXext.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libXi.so.6 /usr/lib/libXi.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libX11.so.6 /usr/lib/libX11.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libSM.so.6 /usr/lib/libSM.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libICE.so.6 /usr/lib/libICE.so
sudo ln -sf /lib/x86_64-linux-gnu/libgcc_s.so.1 /lib/libgcc.so
sudo ln -sf /lib/x86_64-linux-gnu/libc.so.6 /lib/libc.so
sudo ln -sf /lib/x86_64-linux-gnu/libc.so.6 /lib64/libc.so.6

5. Change the command interpreter for shell scripts:
Code:
sudo dpkg-reconfigure dash
Then answer "No" to the question.

6. From DVD1 install Ansys, launch:
Code:
sudo ./INSTALL

7. Modify the Linux environment variable ANSYS quick start of each component Modify the hidden files.Bashrc your Ubuntu home directory. Add the following code in.Bashrc. Method for typing in the terminal code: gedit ~/.bashrc
paste the following code:

# add environment variables:

#ANSYS

# Workbench
export ANSYS180_DIR=/ansys_inc/v180/ansys
alias wb2='/ansys_inc/v180/Framework/bin/Linux64/runwb2 -oglmesa'
export LD_LIBRARY_PATH=/usr/ansys_inc/v180/Framework/bin/Linux64/Mesa:$LD_LIBRARY_PATH
#export XLIB_SKIP_ARGB_VISUALS=1 #uncomment if you have trasparency issues in CFX pre/post or turbogrid
export LANG=en_US.UTF8

#CFX
export PATH=/ansys_inc/v180/CFX/bin:$PATH

#Turbogrid
export PATH=/ansys_inc/v180/TurboGrid/bin:$PATH

#FLUENT
export PATH=/ansys_inc/v180/fluent/bin:$PATH
export FLUENT_ARCH='lnamd64'

8. Type the following code:
source .bashrc

9. To start ansys use any of the following commands:
Ansys CFX Launcher

CFX5
CFX-pre

cfx5pre
CFX-Solver Manager

cfx5-solve
CFD-post

cfdpost
Turborid

cfxtg
Fluent

fluent
ICEM CFD

icemcfd
Ansys APDL

ansys150 # is really in command mode
Ansys150 -g # graphics mode
Ansys Workbench

runwb2
Use the get command to help command -help

Note: The Linux version of Ansys is installed in the Ubuntu is installed by default in /usr/ansys_inc. If you change the default installation location, please modify the path specified in the ansyslmd.ini. Use VIM to open ansyslmd.ini, as follows ANSYSLI_NOFLEX=1 LICKEYFIL=/usr/ansys_inc/shared_files/licensing/license.dat

If the fonts are not displayed correctly in gui, run the following: sudo apt-get install xfonts-75dpi xfonts-100dpi xterm ttf-mscorefonts-installer

You do need to restart your system (it might be enough to restart the X server)!
Abhishek_784 is offline   Reply With Quote

Old   October 23, 2018, 14:52
Default Install ANSYS 18 on ubuntu (x64)
  #5
New Member
 
Abhishek
Join Date: Aug 2018
Posts: 3
Blog Entries: 1
Rep Power: 5
Abhishek_784 is on a distinguished road
This is the step by step procedure that i followed to get ansys running on my machine. This procedure won't give any library issue.

The required packages from the installation guide (for RedHat/CentOS) are:
libXp.x86_64
xorg-x11-fonts-cyrillic.noarch
xterm.x86_64
openmotif.x86_64
compat-libstdc++-33.x86_64
libstdc++.x86_64
libstdc++.i686
gcc-c++.x86_64
compat-libstdc++-33.i686
libstdc++-devel.x86_64
libstdc++-devel.i686
compat-gcc-34.x86_64
gtk2.i686
libXxf86vm.i686
libSM.i686
libXt.i686
xorg-x11-fonts-ISO8859-1-75dpi.noarch
glibc-2.12-1.166.el6_7.1 (or greater)

1. Therefore I installed:
Code:
sudo apt install xterm lsb csh ssh rpm xfonts-base xfonts-100dpi xfonts-100dpi-transcoded xfonts-75dpi xfonts-75dpi-transcoded xfonts-cyrillic libmotif-common mesa-utils libxm4 libxt6 libxext6 libxi6 libx11-6 libsm6 libice6 libxxf86vm1 libpng12-0 libpng16-16 libtiff5 gcc g++ libstdc++6 libstdc++5 libstdc++-5-dev

2. Install manually libXp (not included in the standard repo), you can find it at:
HTML Code:
https://pkgs.org/download/libxp6

3. Update the database with:
Code:
sudo updatedb

4. Locate the following libs and create soft links based on your system. I did as follows:
Code:
sudo ln -sf /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 /usr/lib/libGL.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 /usr/lib/libGL.so.1
sudo ln -sf /usr/lib/x86_64-linux-gnu/libGLU.so.1 /usr/lib/libGLU.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libXm.so.4 /usr/lib/libXm.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libXm.so.4 /usr/lib/libXm.so.3
sudo ln -sf /usr/lib/x86_64-linux-gnu/libXp.so.6 /usr/lib/libXp.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libXt.so.6 /usr/lib/libXt.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libXext.so.6 /usr/lib/libXext.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libXi.so.6 /usr/lib/libXi.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libX11.so.6 /usr/lib/libX11.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libSM.so.6 /usr/lib/libSM.so
sudo ln -sf /usr/lib/x86_64-linux-gnu/libICE.so.6 /usr/lib/libICE.so
sudo ln -sf /lib/x86_64-linux-gnu/libgcc_s.so.1 /lib/libgcc.so
sudo ln -sf /lib/x86_64-linux-gnu/libc.so.6 /lib/libc.so
sudo ln -sf /lib/x86_64-linux-gnu/libc.so.6 /lib64/libc.so.6

5. Change the command interpreter for shell scripts:
Code:
sudo dpkg-reconfigure dash
Then answer "No" to the question.

6. From DVD1 install Ansys, launch:
Code:
sudo ./INSTALL

7. Modify the Linux environment variable ANSYS quick start of each component Modify the hidden files.Bashrc your Ubuntu home directory. Add the following code in.Bashrc. Method for typing in the terminal code: gedit ~/.bashrc
paste the following code:

# add environment variables:

#ANSYS

# Workbench
export ANSYS180_DIR=/ansys_inc/v180/ansys
alias wb2='/ansys_inc/v180/Framework/bin/Linux64/runwb2 -oglmesa'
export LD_LIBRARY_PATH=/usr/ansys_inc/v180/Framework/bin/Linux64/Mesa:$LD_LIBRARY_PATH
#export XLIB_SKIP_ARGB_VISUALS=1 #uncomment if you have trasparency issues in CFX pre/post or turbogrid
export LANG=en_US.UTF8

#CFX
export PATH=/ansys_inc/v180/CFX/bin:$PATH

#Turbogrid
export PATH=/ansys_inc/v180/TurboGrid/bin:$PATH

#FLUENT
export PATH=/ansys_inc/v180/fluent/bin:$PATH
export FLUENT_ARCH='lnamd64'

8. Type the following code:
source .bashrc

9. To start ansys use any of the following commands:
Ansys CFX Launcher

CFX5
CFX-pre

cfx5pre
CFX-Solver Manager

cfx5-solve
CFD-post

cfdpost
Turborid

cfxtg
Fluent

fluent
ICEM CFD

icemcfd
Ansys APDL

ansys150 # is really in command mode
Ansys150 -g # graphics mode
Ansys Workbench

runwb2
Use the get command to help command -help

Note: The Linux version of Ansys is installed in the Ubuntu is installed by default in /usr/ansys_inc. If you change the default installation location, please modify the path specified in the ansyslmd.ini. Use VIM to open ansyslmd.ini, as follows ANSYSLI_NOFLEX=1 LICKEYFIL=/usr/ansys_inc/shared_files/licensing/license.dat

If the fonts are not displayed correctly in gui, run the following: sudo apt-get install xfonts-75dpi xfonts-100dpi xterm ttf-mscorefonts-installer

You do need to restart your system (it might be enough to restart the X server)!
gsiitd likes this.
Abhishek_784 is offline   Reply With Quote

Old   July 6, 2021, 03:20
Default
  #6
Senior Member
 
A. Min
Join Date: Mar 2015
Posts: 301
Rep Power: 9
alimea is on a distinguished road
Hi all

is it possible to install Ansys R1-2021 on ubuntu 20.04?
alimea is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Install ANSYS 14.5 on Ubuntu siqma ANSYS 1 December 6, 2013 01:55
Ansys 13 - License problem on Ubuntu MarTar ANSYS 4 February 3, 2012 02:13
install Ansys 13.0 on Fedora 15 8703303 ANSYS 0 November 7, 2011 10:36
Setting ANSYS Install Folder Using The Command Line rjamison CFX 0 March 22, 2010 22:33
How to Install OpenFOAM on 64 Ubuntu 9.04 hansel OpenFOAM Installation 62 March 19, 2010 14:43


All times are GMT -4. The time now is 21:49.