CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS (
-   -   Strange issue while launching ANSYS workbench in CentOS 6.4 (

Philip_C July 12, 2013 17:48

Strange issue while launching ANSYS workbench in CentOS 6.4
Hi all,

I am trying to launch the ANSYS workbench (14.5.7) in the CentOS 6.4 environment; however, it was not able to be launched successfully. I had no such issue while launch the workbench in the windows environment, and I was able to run individual program such as Fluent in Linux without any issue.

The ANSYS customer support suggested me to change the OS since CentOS was not supported by ANSYS (?); however, based on my understanding that CentOS is based on Red Hat (which is supported by ANSYS). Therefore I would like to know if anyone met the similar issue? and has anyone know how to resolve this issue?


mjgraf July 12, 2013 19:12

sure Support also said to follow the installation instructions?

you must follow the instructions in ai_instl.pdf "Ansys, Inc. Installation Guide for Linux" Chapter 2. Where it states to install or create symlinks, please verify before just doing their instructions. Use yum to check packages and verify the sym link before creating it.

there is a typo where libXp.x86_64 is listed twice, it should be .i686 for the second. So you need both.

If you follow the instructions, it should work. I have Workbench running on CentOS 6.3.

Programs listed in the intro and section, RHEL 6, Ansys Workbench, System Libraries.
Other sections can be performed as needed.

also the error reported would be nice. this typically says what library is missing.

Philip_C July 12, 2013 19:21


Thanks, I have tried to install the library, but the same issue remained...
The error message was very long, and I past the last section of it:
================================================== ===============
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
================================================== ===============

/ansys_inc/v145/Framework/bin/Linux64/runwb2: line 244: 8026 Aborted (core dumped) $MONO_PREFIX/bin/mono $WBII_ROOT/Framework/bin/$ARCH/AnsysFW.exe $WBIIINTARGS


mjgraf July 12, 2013 19:23

you have gone through all the packages in that pdf?

Philip_C July 12, 2013 19:42


Yes, I have tried to update all the listed libraries, but the same issue remained...
The file asked me to install two patch, "kernel-2.6.32-71.14.1.el6.x86_64.rpm and kernel-devel-2.6.32-71.14.1.el6.x86_64.rpm", however, I was not able to find these two patches to install...

Sorry I am not very familiar with linux...
Really appreciate your helps

mjgraf July 12, 2013 21:37

that is just the minimum kernel level. Is you have 6.4, you are running the latest.
to compare, just type
uname -a
in a command line.

allen-cts July 25, 2013 15:40

after reading the manual
Philip-c ,
I had the same error
I finally got it to work by adding the -oglmesa switch
(down in chapter 8.3)

I have it running on Scientific Linux release 6.2

Philip_C July 25, 2013 15:54

Hi allen-cts,

It finally works after months of frustration.

Thank you very much.

mjgraf July 25, 2013 22:41

the mesa enables the software rendering.

just curious
if this is a linux workstation or are you remoting into it from a windows machine using a remote x11 like exceed?

Philip_C July 31, 2013 03:18

Hi mjgraf,

Sorry for the late response. I am using the linux work station.

Although I am able to launch the workbench successfully as in Windows; I am still having trouble to actually launch individual program such as DesignModeler...

mjgraf July 31, 2013 09:39

could be a graphics card driver issue. what card is installed and are the drivers properly installed?

what do you get from a glxinfo
Only need to the top portion, no need for all the table info.

micro11sl August 29, 2013 06:44

The solution by allen-cts works for me! OS: Scientific 6.3
But DesignModeler can't startup. The status just hangs there. Any solutions?

All times are GMT -4. The time now is 13:46.