CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > ANSYS

Unexpected behavior -> oscillation with increasing amplitude

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   June 27, 2020, 09:45
Default Unexpected behavior -> oscillation with increasing amplitude
  #1
New Member
 
Join Date: Jun 2020
Posts: 2
Rep Power: 0
TheBob is on a distinguished road
Hi, I'm barely new to ANSYS and CFD and right now i'm stuck due to the unexpected behavior of the solution of my simulation.

I'm currently working on a model of a centrifugal pump, and i'm especially interesed in the delivery head.

I got a working model, where the delivery head is defined as expression (please see bottom of the post). The pressure is measured at the inlet respectivly at the outlet (arrows in picture 1 "old model").

I'm monitoring the delivery head. The simulation delivers solutions like the one in the picture: a nice pulsation of the delivery head (turquoise) while computing instationary (picture 2 "solution_old_model").

Now, i wanted to measure the pressure at certain points before/after the pump. So i tried to set up a new model, where the pipes consist of two parts, smaller ones to get the desired distance to the pump, and larger ones to avoid changes to the previous model. I tried to mesh the new pipes with the same ratio as the old ones to keep changes as low as possible. After that i created new interfaces to connect the new pipe parts, i used the same interface parameters like the interfaces connecting pump to pipe (so no changes) (please see picture 3 "new_model"). A new expression for the delivery head was defined using total pressure at the desired points (arrows in the picture).

The good thing is: i get a second delivery head which differs from the old one....
The really bad thing is, after being nearly constant for a while, the oscillation starts increasing amplitudes (please see picture 4 "solution_new_model, blue is the delivery head defined by outlet and inlet, the green line is the new, desired delivery head). The RMS are strange too. While in the old model they were oscillating (picture 5 "solution_old_model_rms"), in the new model they are very linear until the oscillation starts increasing the amplitudes as well. (picture 6, "solution_new_model_rms")

I have no idea why my simulation shows this behavior .. i checked back to the old model, found minor flaws, but the behavior didn't change. I double-checked any parameter and except of the additional interfaces to connect the pipe parts, there is no difference (i think). Because of that, the problem have to be the divided parts themselves?

Does anyone know what exactly the problem could be and how to fix it? Or is there an easy way to use the pressure at certain point for a expressian while runtime?

The delivery head is defined like this:

\frac{p_{d}-p_{s}}{g*\rho}

Whereas p_{d} is the total pressure at delivery side, p_{s} is the total pressure at suction side.
The correspondending expression in CFX (both variants) is shown in picture "expression". "Foerderhoehe" means the old one, "Druckrohr Oulet" is the region at outlet, .. "Forederhoehe Messp" is the new one, the region "Messp2" is the one on delivery side, "messp1" is the one on suction side.

Sorry for my bad english. Also, i hope my problem is understandable, if there is any further information required, i will try to provide these, please ask!

Thank you very very much

Greetings.

PS: Due to the max of five files, the two missing pictures will be added in the following answer
Attached Images
File Type: png 1_old_model.png (20.5 KB, 1 views)
File Type: png 2_solution_old_model.png (50.0 KB, 1 views)
File Type: png 3_new_model.png (26.0 KB, 1 views)
File Type: png 4_solution_new_model.png (18.1 KB, 1 views)
File Type: png 5_solution_old_model_rms.png (82.0 KB, 1 views)
TheBob is offline   Reply With Quote

Old   June 29, 2020, 02:33
Default Missing Attachments
  #2
New Member
 
Join Date: Jun 2020
Posts: 2
Rep Power: 0
TheBob is on a distinguished road
As described, the two missing pictures
Attached Images
File Type: png 7_expressions.png (7.0 KB, 0 views)
File Type: png 6_solution_new_model_rms.png (66.9 KB, 1 views)
TheBob is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ANSYS Workbench on "Uncertified" Linux Distros hsr CFX 284 July 29, 2020 03:40
FLUENT installation on UBUNTU 12.04 (LTS) teymourj FLUENT 2 March 1, 2017 22:24
error 262144 and unexpected disconnect when run on 2 nodes Emily1412 SU2 Installation 1 April 10, 2014 17:08
Amplitude of Oscillation mahzad Main CFD Forum 7 July 13, 2013 00:59


All times are GMT -4. The time now is 01:57.