CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   ANSYS (https://www.cfd-online.com/Forums/ansys/)
-   -   ICEM: Surface won't follow the curves (https://www.cfd-online.com/Forums/ansys/228714-icem-surface-wont-follow-curves.html)

AeroFan July 11, 2020 10:46

ICEM: Surface won't follow the curves
 
Hi guys!


I am a pretty new user of Ansys ICEM CFD but I think I recently did a lot of progress to really dig into that program.

So in the context of a paper for my university I got a 2D-geometry file with a farfield and an airfoil with flap, slat, etc. on it and i wanted to define the farfield as my surface and cut out the airfoil using the command "trim surface". After that I noticed, that the edges of the cut-out-surface just don't follow the curves of the airfoil. Especially at the narrow but dull trailing edges of the components its just a big mess. I firstly thought it would only be a display error but turning on "show full" of the surface didn't solve the problem at all. And on top of it I realised that the mesh I generated afterwards followed evenly the edges of the surface and not the curves of the airfoil.

I hope you know some tricks to fix this problem cause otherwise I'll probably be stuck with that paper at that point.


Many greetings!

apsumo September 24, 2020 12:27

are you using blocking? If so, have you associated your edges with your curves?

srsel6 September 25, 2020 10:21

Quote:

Originally Posted by AeroFan (Post 777519)
Hi guys!


I am a pretty new user of Ansys ICEM CFD but I think I recently did a lot of progress to really dig into that program.

So in the context of a paper for my university I got a 2D-geometry file with a farfield and an airfoil with flap, slat, etc. on it and i wanted to define the farfield as my surface and cut out the airfoil using the command "trim surface". After that I noticed, that the edges of the cut-out-surface just don't follow the curves of the airfoil. Especially at the narrow but dull trailing edges of the components its just a big mess. I firstly thought it would only be a display error but turning on "show full" of the surface didn't solve the problem at all. And on top of it I realised that the mesh I generated afterwards followed evenly the edges of the surface and not the curves of the airfoil.

I hope you know some tricks to fix this problem cause otherwise I'll probably be stuck with that paper at that point.


Many greetings!


Hello,

Are you okay with sharing a picture of your problem? It's hard to visualize without a picture.


All times are GMT -4. The time now is 17:06.