CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CD-adapco (
-   -   Iterations not starting (

Konstantinos March 7, 2006 07:19

Iterations not starting
I run the analysis, the geometry file gets written fine, geometrical calculations are completed, i get the problem specification summary, i see the calculation monotoring information table, but the iterations never actually start! Does anyone know why this could be??

Konstantinos March 7, 2006 08:18

Re: Iterations not starting
This is really pissing me off!!! Its been at tha point for about 3 hours and nothing is happening, its not crashing but its not iterating either! And its not stuck, because the processor is working!

kathiravan March 7, 2006 10:03

Re: Iterations not starting
what version you are using. which solver you are using starwatch or run star interactively in star-launch menu. because in my system first i am trying starwatch. but it not stats iterating. but now i am using star interactively it is working.

Mork March 7, 2006 10:12

Re: Iterations not starting
Sounds like it is still chewing on the first iteration. Are you sure you have enough memory for your case? If the computer starts swapping memory, it can get very, very slow.

Konstantinos March 7, 2006 12:49

Re: Iterations not starting
Hi, I am using star-cd 3.26 and i run star interactively in star-launch menu to see the iterations.

I think the memory allocation is fine... I dont know why its so slow, it started iterating now, but it has performed 5 iterations in about 6 hours...

TG March 7, 2006 22:46

Re: Iterations not starting
How big is the problem (how many cells) and how many processors are you running on? How much memory does your system have?

Konstantinos March 8, 2006 06:34

Re: Iterations not starting
Im running on one system with 2Gb ram. I dont know how many cells the model is, because I didnt build the model. I got it off someone else and im trying to run it with different turbulence models. Is there any way to find out how many cells it has?

Mac March 8, 2006 06:40

Re: Iterations not starting

Konstantinos March 8, 2006 06:45

Re: Iterations not starting
2138099 Is this a lot?

Mork March 8, 2006 07:46

Re: Iterations not starting
Depends what you want to do and what your hardware looks like. I strongly recommend to spend a little time on learning about CFD...

Konstantinos March 8, 2006 07:52

Re: Iterations not starting
Im definately gonna read about it and learn it, its just that in two days i have a short presentation and im trying to run at least one model so i can show them some results :p

matej March 8, 2006 08:31

Re: Iterations not starting
if you want some results in 2 days get some pictures from the internet and do some reading and tutorials. No one can say you a word if you're not able to get a results on such a mesh. Even experienced expert can spent weeks on more simple tasks than yours.


TG March 8, 2006 08:59

Re: Iterations not starting
STAR roughly uses 1Gb of memory for 1e6 cells so with a 2 Gb machine you are on the very edge of what you can do. You might be a bit over which means you swap which means you run even slower. As everyone here said, if you want to run faster you need to run parallel on more than machine. The times you are seeing per iteration are not unreasonably long for that size model for 1 processor with maybe not enough memory. You can remesh and create a smaller model and it will run faster but you will also lose accuracy. Depending on what you are looking at, 2e6 cells may not be enough either. If all you want is some pretty pictures then you can certainly cut the mesh down.

Mork March 8, 2006 09:51

Re: Iterations not starting
Now I understand your desperation. You have either been given an unrealistic deadline or you have to work on your time management.

Konstantinos March 8, 2006 09:58

Re: Iterations not starting
My time management has been the best i think :p

All times are GMT -4. The time now is 20:43.