CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Swirl ratio failure in remeshing in CFX (

a_cucen May 4, 2012 10:27

Swirl ratio failure in remeshing in CFX
1 Attachment(s)
Dear all,

I want to run an internal combustion engine simulation with CFX. I have connected CFX and ICEM-CFD. I have made some analysis so far but after most of the remeshing sections in ICEM-CFD, swirl ratio changes. I have attached a pictures shows this situation. I have tried different mesh sizes, but result is the same. How can I fix this situation?


ghorrocks May 5, 2012 07:12

The fix is easy - use the IC engine modelling wizard in workbench :) It uses Fluent as the solver as it has much more IC engine stuff in it that CFX does.

I have no idea what your remeshing problem is. Save a results file before and after a remesh and see if you can spot the problem.

a_cucen May 5, 2012 07:29

I have found an extension package that you can use ICE very effectively but this failure happened. The tutorials work fine but when I prepare my simulation like tutorial, it causes this error.

ghorrocks May 5, 2012 07:31

Have you looked at the flow field immediately before and after a remesh? Do they look the same?

a_cucen May 5, 2012 10:05

Yes they look like the same. This failure happens in averadge of pressure in domain. Swirl ratio was one of an example.

ghorrocks May 6, 2012 06:46

If they look the same then why is the swirl ratio different?

Is the thing which is not carried over smoothly the pressure? That could affect swirl ratio through the density.

a_cucen May 6, 2012 07:53

Yes after remesh phase pressure could not been carried over smoothly. It changes just like swirl ratio, so physics of this case fails I think. and It s not depend on mesh sizes or time step sizes. I have not found a solution yet.

ghorrocks May 6, 2012 20:11

So the problem is the pressure is not being carried over smoothly in remeshes, and the swirl ratio change is just a symptom of that.

a_cucen May 7, 2012 03:02

I don' t know. And I haven' t found any solution yet. Really lost in here. Do you have an idea about this situation?

ghorrocks May 7, 2012 06:59

Other than saying the problem seems to be in mapping the pressure over, no. You will have to do some investigation and try to track it down. Contact ANSYS support if you need to.

a_cucen May 7, 2012 14:11

Dear Glenn,

Maybe I can change cfx to Fluent but IC engine modelling wizard in workbench is only modelling cold flow, not combustion. How can I model combustion in this wizard?

ghorrocks May 7, 2012 17:13

I have never used the wizard so do not know, but I am sure you will be able to include combustion in the model. Fluent has many combustion models.

Shahr March 1, 2013 05:13

I am sorry that I resurrect this thread. I think I have same problem with pressure field after remeshing. My simulation is not an ICE one though.

My question has been answered previously in here. But I don't expect to have same problem after every single remeshing step.

The velocity field is nicely transferred to the new mesh; The pressure field however has weird mismatching behaviour. Has anybody found a solution for the problem?

ghorrocks March 3, 2013 06:08

The thread you quote is talking about initial conditions. This thread is very different - it is about mapping the ersults over to a new mesh and continuing a simulation. This appears to be some problem with the interpolator.

Shahr March 4, 2013 12:11

Thank you for reminding, Mr. Horrocks. I am aware that my previous question was about initial conditions, but if I run the simulation long enough, the pressure will be fixed after some time steps. However, every time remeshing takes place, interpolation (remapping) of pressure field is done wrong, and the same behaviour repeats. This, I believe is similar to the problem mentioned in this thread. You can see this plot from my monitors:

ghorrocks March 4, 2013 17:28

You will have to do a bit of research your self on this one. Have a look at the pressure field immediately before and after a remesh. Do you see any differences?

All times are GMT -4. The time now is 22:32.