CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Error with CFX-pre coz CFX-Solver not run (

mariam.sara August 9, 2012 07:23

Error with CFX-pre coz CFX-Solver not run
Hi I am trying to implement a transient case of stratified two phase (air-water) flow with using inhomogeneous model when I tried run the case by pressing define Run the following warning appeared and cfx-solver not start.
Validation of the problem physics was unsuccessful
The current physics state is :
• Global Error and warning count = 0
• Specific Error and warning count=1
• Expression Error count=0
This case may not run in cfx-solver.
When I view the error the following message appear below:
Dependency Error in object "/FLOW:Flow Analysis 1":
The object "MESH ADAPTION" is present in the object "/FLOW:Flow Analysis 1" but it is not physically valid.

I tried deselect the mesh adaption but the error still exist so what the problem? Any help is appreciated?

Mariam August 9, 2012 07:41

There is surely something wrong with the setup you have done. Have you tried the tutorial " Free surface flow over a bump". Please check through your settings again or if you can post the ccl of the setup, it would be more helpful. Also it would be really nice if you could explain you problem more clearly.

mariam.sara August 9, 2012 07:50

1 Attachment(s)
Hi i sent you the CCL for my case see attach file. I tried to simulate two phase stratified air-water flow in a pipe I want to predict from my case the velocity profiles for the phases and study the nature of wavy interface depending on the inlet velocities this quick description to my case.

evcelica August 9, 2012 20:03

Oh this is an easy one!
You cannot use mesh adaptation in a transient case, only steady state. Lose the mesh adaptation and it should run fine. Try saving, reloading, and closing and reopening the file to write a new .def file without the mesh adaptation.
I hope I'm right or I'll look stupid :)

mariam.sara August 13, 2012 00:31

Hi Erik I tried change the .cfx name and saved it same problem exist even I tried changed .def file with deselecting mesh adaption no changes made and the error still appeared?


evcelica August 13, 2012 20:01

Somehow, something about Mesh adaptation is still there in the .def file. Do you get any warning messages in PRE about the mesh adaptation? You have turned it all off, everywhere in PRE? And in the solver manager you have reloaded the .def file and are starting from initial conditions?
As a last resort, would it be difficult to just import your original mesh into a whole new CFX-PRE case and redefine all your conditions without the mesh adaptation? This would definitely work, but would require a little more work.

mariam.sara August 14, 2012 03:27

Yes I got warning message in cfx-pre but when i go to mesh adaption it tell me it not available under multi-domain problem and transient......etc so I turn transient off and go to mesh adaption then deselect it (the warning disappear with this) then I transform it to transient after that i save the case and initialize the case just i press run and save the .def file the message return with cfx-pre ? if am so grateful if you can have a look through my cfx-pre file I can post it here?

Lance August 14, 2012 04:00

Why not just start over with a new file? You've had this error for at least five days now and it would have been much easier to just start up a fresh cfx, load the mesh and redefine the BCs.

All times are GMT -4. The time now is 15:52.