CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Simulation of dispersion of oil droplets in water -two issues (

milan.2012 November 15, 2012 12:06

Simulation of dispersion of oil droplets in water -two issues

I am working with modeling of multiphase flow using cfx, specifically dispersion of oil droplets in water flowing through a pipe. The dispersion presents experimentally different droplet diameters.
To model the issue I will use a eulerian eulerian approach with the particle model using two alternatives:
- the water as a continuous phase and the oil as four independent dispersed phases with different diameters.
-Use the inhomogeneous MUSIG model.

- For the first alternative i am getting an error after trying to start the simulation in the solver manager. The error is the following:
Error in subroutine FNDVAR :
Error finding variable ROTVEL
GETVAR originally called by subroutine get_DOMVEL
| ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| Stopped in routine GV_ERROR |

Do you know what might be causing it?

- for the second alternative, the inhomogeneous MUSIG model is not available as an option when i select the oil as a polydispersed phase, only the homogeneous MUSIG appears. Why is that? Is there maybe a license limitation for the academic version in my university?

Thanks for all the possible help you can provide


ghorrocks November 15, 2012 18:00

The error message is cryptic, but appears to be looking for (and not finding) a variable associated with domain motion. Is this a rotating frame of reference simulation? Or are you using the translating domain beta feature?

milan.2012 November 15, 2012 18:21

Hello Glenn

No, no movement at all. The domain is a simple pipe with inlet and opening. I scaled the mesh though because the diameter had to be smaller than how it was originally constructed.

I ran the same case with only one particle size and it runs ok.



ghorrocks November 15, 2012 18:23

It appears to be looking for domain rotation information and not finding it. Check whether the domain has been set to rotating or some other mistake like that.

milan.2012 November 16, 2012 08:50


The problem is caused by insufficient available memory to run the simulation. First issue solved.



milan.2012 July 24, 2013 03:33

Answer to the second issue:

To activate the inhomogeneous MUSIG model (CFX 13.0) you have to "Enable Beta Features" in the CFX-Pre Options Menu, under the category: "General".


All times are GMT -4. The time now is 16:40.