CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Define run fails (

Thomashoffmann November 20, 2012 09:35

Define run fails
1 Attachment(s)
hi all.
I have set up my simulation in CFX-Pre. But when I want to define run, it gives me an error and exits with return code 1.
I'm simulating a non Newtonian material and get the error. I have tried to switch the material to water and then the solver runs fine. Does anybody know what to do?


cdegroot November 20, 2012 10:11

Looking at your error, it is trying to find the reference temperature for your material and cannot. Have you defined this in Pre?

Thomashoffmann November 20, 2012 11:09

ok. No I haven't done that. But what does it mean? My fluid is -5.5degC at the inlet and might stay within 0.5degC through my simulation. What should the reference temperature then be?

cdegroot November 20, 2012 11:19

The solver needs a reference temperature in order to define a reference enthalpy. See the theory guide, section 1.1.3. (Variable Definitions). The reference value shouldn't affect your solution as long as it is within range of what you expect to see in your simulation.

Thomashoffmann November 20, 2012 12:02

allright. Thanks - I'll read through it :)

Thomashoffmann November 20, 2012 15:11

4 Attachment(s)
I have set up the reference values in my material now, And I still can't run my solver. See attached pictures for my material definition and my details of error.
Do you see any clear mistakes I have made?

cdegroot November 20, 2012 17:09

It seems to be complaining when allocating space for variables. Did you add any additional variables?

Thomashoffmann November 21, 2012 05:04

yes I have added a couple of things.
I tried changing my material to water and the solver did not complaint. Then I changed my parameters one by one until I found out that my thermal expression is leading to the error.
I used
k=-0.000837 [W m^-1 K^-3]*T^2-0.030641 [W m^-1 K^-2]*T+0.147212 [W m^-1 K^-1]
Maybe I have to define that T is the temperature? Do you know how?

brunoc November 21, 2012 10:18

Did you set initial values for the temperature field?

Thomashoffmann November 21, 2012 10:29

hmm, I'm not sure. I have defined the inlet temperature (that's not what you ment, right?). I did this in my default domain and then fluid model. There is also an initialization tap, which I haven't touched...

Where do I set it up?

brunoc November 21, 2012 11:11

At the initialization tab.

Thomashoffmann November 21, 2012 11:17

1 Attachment(s)
but there is no temperature initialization properties...? see attached

cdegroot November 21, 2012 11:32

Have you turned on the energy equation?

Thomashoffmann November 21, 2012 11:33

probably not... Where do I do That? (I'm new in cfx, if you didn't notice)

cdegroot November 21, 2012 11:36

Double click on your fluid domain to bring up its details, then go to the "Fluid Models" tab. Under "Heat Transfer" choose which energy equation you want to solve. Probably thermal energy is fine for your case.

brunoc November 21, 2012 11:41


Originally Posted by Thomashoffmann (Post 393461)
probably not... Where do I do That? (I'm new in cfx, if you didn't notice)

You might want to do the tutorials before solving your real problem. You can learn lots of things from them, including some best practices. Also, you might be missing more stuff to your model that could potentially affect the final results.


cdegroot November 21, 2012 12:18

Bruno makes a good point. Go ahead and continue to play with this model if you want, but if you are looking to use the results it would certainly be a good idea to go through some CFX tutorials to make sure you aren't missing something fundamental in your model.

All times are GMT -4. The time now is 17:35.