CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Effective heat capacity - Phase change does not work!!! (

papteo January 15, 2013 10:29

Effective heat capacity - Phase change does not work!!!
2 Attachment(s)

I am trying to simulate a PCM with the CFX. To simulate the phase change , i wrote an expression varying the heat capacity depending on its temperature in order to implement the effective heat capacity for the melting phase. The normal value of the specific heat capacity is 1200 J/(kg K) and during the melting area 100.000 (J/kg K). My problem is that I do not obeserve any change at the temperature during the phase change while the Cp has the right value according to my simulation! The temperature should have remained constant for a certain time or at least the temperature increase should have been smoother

I am attaching also two photos from the post-processing which show the Cp and Temperature over time!

Can anyone help me with this problem?

step January 15, 2013 12:00

Hi there,

I would also be interested in a solution. I've found some bits of literature that suggest an approach using an effective heat capacity to account for the energy necessary for a phase change.

Any ideas?

ghorrocks January 15, 2013 21:57

What are you actually modelling? How are you driving the temperature?

papteo January 16, 2013 04:49

Hi Glenn,

thank you very much for your interest. What I am actually doing is to test the principle of the effective heat capacity for a phase change material. I am modelling a cube (PCM-solid) which has an initial temperature of 45 C and one side is heated up with 10.000 W/m . The PCM has a very high Cp value within the melting field (e.g. 50-60 C). As mentioned above my goal is to monitor a constant temperature within this temperature field. Instead the temperature is rising without observing any change at the temperature contrary to the Cp value as the pictures show.

Do you have any ideas why this is happening?

Thank you very much in advance

ghorrocks January 16, 2013 17:45

Obviously your variable CP is not beign applied. Check that it is the CEL properly. Also check that the table CFX uses to model variable properties is appropriate to capture the non-linear bits of your Cp curve. You might need to tighten the table temperature limits, or put more points in the table.

papteo January 17, 2013 10:20

Thank you very much Glenn for your advice. I just increased the number of the points and the problem was solved.

Once again thank you for your help and quick answer! :D:D

jjdd2011 October 23, 2013 21:16

Thank you for your help. Just wonder where is the table CFX used to model variable properties.

ghorrocks October 24, 2013 05:27

It is internally generated. You define how many points the table has, but do not access the table directly. You can see its result by looking at the material properties it ends up with in the post processor if you like.

jjdd2011 October 31, 2013 06:15

Thanks a lot. After I have posted the question, I realized that it can be in material property setting. I changed the number of points. It worked. Great help.

All times are GMT -4. The time now is 01:47.