CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Rotor-Stator alignment in Frozen Rotor (

RPFigueiredo April 12, 2013 06:59

Rotor-Stator alignment in Frozen Rotor
1 Attachment(s)
Hello everyone!

I am currently intending to analyse how the relative position of the rotor-stator system influence the flow in a turbine annulus (using Frozen Rotor). However, as I don't have much available time. I would like to know if it is at all possible to obtain this by re-positioning the mesh and using some clever commands.

As seen in the image below, this realigning would prevent me from changing the blade position in the rotor CAD model itself and re-meshing everything again...

Attachment 20684

Any ideas?

Thank you in advance!

ghorrocks April 12, 2013 07:48

Yes, this is possible. In fact for many cases it will be a very good approximation of the true flow and much quicker and easier to do than a full transient model.

Also, you will only need to mesh this once. In CFX-Pre you can transform the mesh to the new positions and re-run. And I think you can also parameterise it so you can run it as a single big job in workbench.

RPFigueiredo April 12, 2013 07:56

Thanks for the reply. Would you please be kind enough to quickly point out on how to reposition the mesh on CFX-Pre and how to to set the new interface?

Thanks again!

ghorrocks April 12, 2013 07:59

Go to the mesh object, right click, transform. It is also described in the documentation.

RPFigueiredo April 12, 2013 10:27

Thank you, that was really helpful information.

However, there was an overflow error with this computation:

| ERROR #001100279 has occurred in subroutine ErrAction.
| Message:
| Floating point exception: Overflow

| ERROR #001100279 has occurred in subroutine ErrAction.
| Message:
| Stopped in routine FPX: C_FPX_HANDLER

That didn't happen before (with the original alignment). Do you believe there's a set-up error? Or changing the time step could help?

ghorrocks April 13, 2013 07:55


RPFigueiredo April 14, 2013 08:30

1 Attachment(s)
I tried using double precision and decreasing the time step - none of them solved the issue however.

I wonder if there's something else I should do to the set-up. Since they're not properly aligned (see picture below), is there something I should change in the interface?

Attachment 20722

ghorrocks April 14, 2013 18:26

Providing you have set up your rotating frame of reference and GGI correctly this misalignment should be OK.

The FAQ talks about a lot more than just double precision and time step size. Please consider all the points on this FAQ.

RPFigueiredo April 14, 2013 18:28

By GGI what do you mean? All I've done was to set the pitch change to none, and frozen rotor.

Did some research, perhaps there's something to do with this?

And think I solved it... Apparently I should be using the Rotational Offset option described in the following link.

It is important to note that you can't use this Rotational Offset feature with the pitch change set to 'none', given it's not exactly aligned. The solution was to set it to value=1 (ie no pitch change).

Now things seem to work! Thank you very much for the help.

All times are GMT -4. The time now is 20:02.