CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   CFD Post Error (

lycoming September 24, 2013 08:22

CFD Post Error
When opening CFD Post I'm getting the following error:

"Application Error in CFD-Post: ERROR
No locators provided in Location parameter."

I'm still able to post process the results, but I haven't had any success in correcting the error. Has anybody seen this before, and how do I correct it?

titanchao February 13, 2015 13:35

I am encountering the same problem. Did you find a solution. Thanks!

ghorrocks February 13, 2015 19:30

The error message looks pretty clear to me. You have a CFD-Post object which has no location object associated with it. You can get this with state files or session files where objects which existed in previous simulations have now disappeared.

Simply give the unhappy object a location object and it will be happy.

titanchao February 13, 2015 19:44

could you plz let me know what u refer to as state files or session files? also could u plz elaborate on how to give the "unhappy object" a location object?

thx - appreciate it

ghorrocks February 14, 2015 05:32

You had better describe what are doing to get the error then.

titanchao February 14, 2015 17:12

the error msg popped up when i was attempting to open the case and data file in cfd-post, although they can open without a problem in Fluent

ghorrocks February 14, 2015 22:31

So I assume this is a Fluent simulation you are trying to open in CFD-Post.

What is the model? What physics does it include?

burak_ekmekci March 15, 2015 15:00

1 Attachment(s)
ı am getting this error message when ı try to load fluent results data in cfd post ? is there anybody to help me? thnx

ghorrocks March 15, 2015 18:21

There appears to be something fundamentally wrong here. You are crashing the software so either your fluent files are corrupt enough that it can crash CFD-Post, or you have found a bug in CFD-Post. Even if your files are corrupt you would hope CFD-Post was rugged enough to be able to reject the corrupt file and stay alive.

So I would report this to ANSYS support as a possible bug in CFD-Post.

kar.coep May 18, 2015 02:35


Were you able to solve this error?

Letan September 11, 2015 22:05

Have you tried checking the assigned locations to any items under User Locations and Plots. Maybe what happened was at your initial post-processing you created say a contour plot that was assigned to a certain LOCATION. Then maybe you did some modifications to say your boundary conditions in the Setup causing the deletion of that LOCATION previously assigned to the contour plot. Hence the error keeps on popping out unless these locations were updated.

siamak1438 April 28, 2017 23:37

I had the same error and found how to fix it. Because you changed the folder location or renamed it, workbench cannot find the file location assigned before. So, what you need to do is to find the *.cst file (in workbench folder) and open it with notepad. The assigned folder location or name is stored somewhere in this file, just scroll down to find it. So, change the name of location as it was before.

All times are GMT -4. The time now is 19:15.