CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   CFX (https://www.cfd-online.com/Forums/cfx/)
-   -   Error ‘The path is not of a legal form.’ in Workbench running CFX (https://www.cfd-online.com/Forums/cfx/155338-error-path-not-legal-form-workbench-running-cfx.html)

Anna Tian June 29, 2015 04:16

Error ‘The path is not of a legal form.’ in Workbench running CFX
 
1 Attachment(s)
Hi,

I use Ansys 16.0 workbench to run CFX simulations by ‘Table of Design Points’ in ‘Parameter Set’.

Here is the problem

The ‘Update’ button could run the ‘DP0(Current)’ simulation normally(successfully). But when I use ‘Update All Design Points’ button, I got error information ‘Update of the Solution component in XXX for design point # failed: The path is not of a legal form.’

I think the problem shall be from the ‘Solver Input File’ path setting in ‘Run Definition’ as whether I setup an initial value or not, the error remains. The setup I did is shown in the figure attached. I tried different ‘Solver Input File’ paths, e.g. ‘…./dp0/CFX/CFX/XXX.def’ but none of them works.

It seems the original default setting, which is a path to a non-relevant folder and not existing file that makes no sense, could work all things well. But how to recover to the default setting?

May I ask why I got this error message and how to solve this problem?

Anna Tian July 1, 2015 05:18

Quote:

Originally Posted by Anna Tian (Post 552516)
Hi,

I use Ansys 16.0 workbench to run CFX simulations by ‘Table of Design Points’ in ‘Parameter Set’.

Here is the problem

The ‘Update’ button could run the ‘DP0(Current)’ simulation normally(successfully). But when I use ‘Update All Design Points’ button, I got error information ‘Update of the Solution component in XXX for design point # failed: The path is not of a legal form.’

I think the problem shall be from the ‘Solver Input File’ path setting in ‘Run Definition’ as whether I setup an initial value or not, the error remains. The setup I did is shown in the figure attached. I tried different ‘Solver Input File’ paths, e.g. ‘…./dp0/CFX/CFX/XXX.def’ but none of them works.

It seems the original default setting, which is a path to a non-relevant folder and not existing file that makes no sense, could work all things well. But how to recover to the default setting?

May I ask why I got this error message and how to solve this problem?

Could anyone help on this question?


All times are GMT -4. The time now is 20:39.