CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Compilation on Tascflow 2.11 (

cfd guy February 4, 2002 11:52

Compilation on Tascflow 2.11
Hi people,
I would like to discuss with you about User coding compilation on Tascflow. I work with Windows NT and I have Exceed 6.1 and Visual Fortran 6.5 installed on my system. The first version of Tascflow I used was 2.10 and there were no problems at all on that version, I did every user coding I wanted... But when I received the 2.11.00 version I began to notice problems on compiling my subroutines. The 2.11.01 version has been released and this problem still persists, so if I want to use my subroutine I must switch back to the 2.10 version. I use the usrgrd_point subroutine. The Solver Monitor doesn't tell me the reason why Tascflow doesn't compile my case file, it just tell me this output:

Making tascflow3d_local.exe executable. This may take a few minutes.

ERROR: Local executable not made.


I've been stuck on this for months and I still have no answer for it. So, is there anyone with similar problem?
Regards, cfd guy.

andreis March 1, 2002 05:48

Re: Compilation on Tascflow 2.11
hi there

Am having the exact same problem with the same error message on TascFlow 2.11.1 - sorry, no that much help.

Running 2000Pro, Exceed 7, Visual C++ 6

cheers aandreis

cfd guy March 1, 2002 14:20

Re: Compilation on Tascflow 2.11
Hi andreis,
I knew that I was not the only one. Did you make any contacts with the support people?
Regards, cfd guy

Tasca March 7, 2002 10:16

Re: Compilation on Tascflow 2.11
Hi you,

TASCFlow needs "cl.exe" file (C++ compiler) to build your executable local file. Try install a C++ compiler in your PC an try to compile your routine.



andreis March 15, 2002 12:30

Re: Compilation on Tascflow 2.11
Hey cfdguy

Manage to solve my problem... My environment variables were messed up. Fortran couldn't locate the temp files it was creating. Once I was able to compile the user code in Fortran (6.1), then TascFlow 2.11.1 had no problems

Cheers andreis

cfd guy March 15, 2002 13:07

Re: Compilation on Tascflow 2.11
Hi andreis,
My problem has been solved, thanks to Tasca. In fact, C++ was missing and Tascflow could not find the "cl.exe" compiler. Now I have both Visual Fortran 6.5 and the Visual C++ 6.0 compiler. You can do a simple test and see what is your error message. Open your Application Launcher and go to Console (Under menu Tools). Now execute this command:
Tascflow3d -local code -build (Don't forget to copy your fortran files to "code" directory)
Depending the error message you can diagnose what is going on. If it's not anything to do with the "cl" command, your error must be due an environment problem.
Good Luck! cfd guy.

All times are GMT -4. The time now is 19:38.