CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   can't open database cfx 5.5.1 (

Olivier Macchion September 25, 2002 03:14

can't open database cfx 5.5.1
Hej all,

At the beginning I performed my computations on an Alpha machine running under Linux redhat. But now the lab has bought a PC running under Debian Woody. When running on the Alpha I had no problems in opening old databases. But now that I run on the PC with woody as OS, I can sometimes open a database, at other times I can not. In some ways I must do something that corrupt the database. I explain what I do usually with the databases.

I first create the geometry and meshes it with a coarse mesh. I write the definition file. Then, after the first run, I open again the database, make my changes on the mesh, write the new definition file with the same name, and performs the run. And now, after the run, I can no longer open the database. When I open it, it says the following :

$# The available hardware graphics driver initialized for use has been set to the OpenGL graphics driver. $# Current graphics driver type in use: Hardware driver $# Session file started recording at 24-Sep-02 15:50:38 $# Recorded by: CFX-Build 5. $# FLEXlm initialization complete. Acquiring license(s)... $# License File: /afs/ $# CFX-Build 5 has obtained 1 concurrent license(s) from FLEXlm per a request $# to execute on a Linux ix86 system at 24-Sep-02 15:50:38 uil_file_open.go("./sst.db") $# Database version 2.6 created by 2001 r2 successfully opened.

But the viewport is not there, and I can not do anything because the red light is always on.

The same way the small window that says "Setting up windowing environment" does not disappear.

Is there someone who has had the same problem before ?

Thank you


Fredrik October 7, 2002 05:29

Re: can't open database cfx 5.5.1
Hi Olivier,

I have the same problem opening database files. I am running cfx5.5.1 on debian GNU/Linux with kernel 2.4.19. Sometimes it works and other times it doesn't. I have sent the question to AEA with an example file, but since they dont experience any problems opening the file in any of their platform it is hard for them to come up with an idea. Moreover it gets difficult to figure out the problems on my machine beacause it sometimes works to open files wich in the second earlier were impossible to open.

My guess is that it has to do with the windowing system. The viewport somehow get lost or dissapers from the desktop.

I have the same symptoms as you do, the cfx5build stalls and indicates than database is successfully opened, but red light flashes and nothing happens.

I will have to examine what the problem could be. Please tell me if you come up with an idea!



Olivier Macchion October 7, 2002 05:52

Re: can't open database cfx 5.5.1
Hi Fredrik !

I think you are right because when I sent my database to the cfx guy he said that the viwport was lost and that I should do : Viewport -> Tile But the problem is that we don't get to the menus.

It seems strange but I think that it has something to do with libraries that are located in different places in RedHat and in Debian linux. The thing is that when I run a computation and I open at the same time Build, Build opens all the databases that can not be opened otherwise. But I haven't a clue on the truth of what I'm writing.

It's the only progress that I have been able to do until now. In order to be able to work I have written a session file that I play whenever i need to change something in my model.

If you come up with something more, could you write please ?



Olivier Macchion October 7, 2002 08:17

Re: can't open database cfx 5.5.1
Hi Fredrik !

In fact it's simply that it ends the viewport in another viewport of your linux machine. You just have to look for it in the other viewports and it will stop to stall as soon as it appears on your screen



Fredrik October 7, 2002 09:19

Re: can't open database cfx 5.5.1
Hi Olivier!

I tried your method to let cfx5 process something while open build and it opened the file without problem! Hmm pretty strange indeed.

I have allso noticed that cfx5 sometimes opens the window in an other viewport as you said. But that is only occationally. Most of the time I can't find the window.

Well, nevertheless it seems to be problems with the graphic window placements. Pretty strange.



All times are GMT -4. The time now is 23:50.