CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   MEMERR error in 5.6 (

Astrid July 14, 2003 11:03

MEMERR error in 5.6
Hi all,

we often run into a MEMERR error when we run a case over 5 cpu's. Using 4 cpu's doesn't give this problem.

What can it be? Details are given below.

Cheers, Astrid

================================================== ====================
OUTER LOOP ITERATION = 501 ( 1) CPU SECONDS = 3.93E+05 ( 8.71E+02)
| Equation | Rate | RMS Res | Max Res | Linear Solution |
Slave: 4
Slave: 4 Details of error:-
Slave: 4 ----------------
Slave: 4 Error detected by routine MAKDAT
Slave: 4 Illegal data area length CDANAM = LCON CDTYPE = INTR ISIZE = 0
Slave: 4 CRESLT = SIZE

Parallel run: Received message from slave
Slave partition : 4
Slave routine : ErrAction
Master location : RCVBUF,MSGTAG=1032
Message label : 001100279
Message follows below - :

| ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| Stopped in routine MEMERR |
| |
| |
| |
| |
| |

Glenn Horrocks July 14, 2003 18:32

Re: MEMERR error in 5.6
Hi Astrid,

I have no experience with this particular error, I suspect it is some sort of bug in CFX. Double check that you are doing everything correctly, then you should contact your CFX support rep, and report the details of the bug, and if possible a def file which demonstrates the problem. I have found CFX very good when presented with a significant bug in the program, they generally fix it quite quickly.

Also if you chase this up with them, then it will probably get fixed in the next patch release, then the problem will be fixed up for everybody!


Johnson July 14, 2003 19:33

Re: MEMERR error in 5.6
Hi Astrid

It may be something to do with the partitioning and/or if you have GGIs non-overlap boundaries. You should be able to check the partition geometries by doing a partition only run and viewing the real partition number in CFX-Post.

Try using a different partitioning algorithm (from the Solver Manager) to see if this helps.


Bart Prast July 15, 2003 05:10

Re: MEMERR error in 5.6
What's your hardware configuration: cluster of identical 1 CPU PC's, SMP machine?

Astrid July 15, 2003 06:43

Re: MEMERR error in 5.6
5 identical CPU's with Windows NT4 at 1.7 GHz with 1 Gb Ram of memory. They are standalone machines in a distributed network at 100 bt connected with a hub. Don't see a problem here.


Bart Prast July 15, 2003 06:48

Re: MEMERR error in 5.6
Indeed not a problem. You haven't interpolated old results on an existing res file btw? In 5.6 this is a problem for us. We can interpolate a res file on an empty def file. But interpolating to a def/res file already containing a result, gave a similar result (crash at first iteration). Other then that I do not see why it should crash on you.

Astrid July 15, 2003 10:10

Re: MEMERR error in 5.6
Hi Bart,

First, I ran a case for 500 iterations with the k-e model and scalable wall functions. Then, the results are used as an initial guess for a new definition file with SST and Automatic wall functions. Thus not a direct interpolation, but...........

BTW, do I read it correctly, you interpolate results on a results file? What's the results? On what kind of restart is it useful?


Bart Prast July 15, 2003 10:13

Re: MEMERR error in 5.6
If you do not keep def files, your res files contain all information (grid etc). But even if you made a mistake with your first interpolation (wrong source file) and you do it a second time with the right source file, the solver crashes (in our case at least)

Neale July 16, 2003 00:52

Re: MEMERR error in 5.6

This problem is fixed in the 5.6 Flow solver patch update. Download and install it and things should be fine.


Astrid July 16, 2003 03:00

Re: MEMERR error in 5.6

Thank you for the prompt service. I will be monitoring the community site to see when it has been posted.


Michael Bo July 16, 2003 05:29

Re: MEMERR error in 5.6

Astrid July 16, 2003 05:56

Re: MEMERR error in 5.6
Hi Michael,

Thank you for the link. Can you tell me why it isn't on the community page yet? Is it a beta patch?


Astrid July 16, 2003 05:59

Re: MEMERR error in 5.6
And the other patch ..... CFX-5.6-WINNTPATSM-030708.exe. Is this one for S(olver) M(anager)? What does it fix?


cujo July 17, 2003 02:56

Re: MEMERR error in 5.6

I can't open this link. We have exactly the same error (same number, same partition) here when running CFX56 on 10 processors.


Sam Z July 17, 2003 03:54

Re: MEMERR error in 5.6

We're having a similar problem here... Please can you post some information about how to install these patches and what they do.

There is still nothing on the CFX Community site

Thanks alot

Sam Zakrzewski

Neale July 17, 2003 10:53

Re: MEMERR error in 5.6
It's not on the Commnunity site yet because there are also CFX-Pre and CFX-Post patches in the pipe. They will be posted on the Community site when they are all ready.

There are other bugs fixed in the solver patch. When the posting goes up on the community site you will see


Astrid July 17, 2003 19:19

Re: MEMERR error in 5.6
Ask for a login code at your local helpdesk.


Astrid July 17, 2003 19:22

Re: MEMERR error in 5.6
Does the patch for Post fixes the 'bug' that 2D regions in a GTM file are invisible?


bolus13 November 22, 2016 04:11

Errors in run with mutiple subdomains
wrong place to post, apologies. can not remove

All times are GMT -4. The time now is 10:46.