CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   4 No data source for workspace (

Greg August 10, 2004 22:42

4 No data source for workspace
Hi, CFX Users!

I Run CFX 5.6 and most of the times I get two subsequent messages at the beginning: from the solver: "No data source for workspace, cannot monitor Solver data."

Could anybody tell me where do I make my *.def file corrupted or what?


CTR Developments January 3, 2015 04:39

Hi, bit of a thread revival! But does anyone know what this error means, and better yet, how to fix it?


ghorrocks January 3, 2015 05:38

I have never seen that error before. Are you sure your CFX installation is OK? Do the tutorial examples run OK? What are you modelling?

CTR Developments January 3, 2015 06:23

I will double check. I have only started to come across it just before Xmas. Attempting to model a complete car (simplified). I have done it before with a very similar model (the wings in different positions etc) with no issues. It does appear to solve the simulation, but whilst running I don't get any outputs such as the graphs or text info, but I do get data that will run in CFD Post that looks sensible. I will go back to some previously working models and see if they still work!

ghorrocks January 3, 2015 06:37

It looks like a Solver Manager error, not a solver error. Solver Manager only views and controls the simulation in progress, it is not the solver itself. So your solver is probably running fine.

The error probably means it is looking for a running simulation directory and cannot find one. Check that a run is in progress, and that the correct directory is chosen. CFX runs in a temporary directory called .cfx_tmpdir when it is running. This directory is deleted when a run completes, and all the results file stuff is transferred to the final location.

CTR Developments January 3, 2015 09:50

I will have a look at this, cheers. I am now carrying out a re-run of an earlier test and all seems to be OK though. When it is finished I will retry the troublesome one!

CTR Developments January 3, 2015 11:58

Hmm, seems to have been peculiar to that specific setup. New setups are running as are the other pre-existing ones. But for whatever reason that setup gives me errors. I have tried to recreate it all from scratch and I still get the error... Anyway, thanks for the help and advice

Soolmaz January 28, 2016 03:57

1 Attachment(s)

I get the same error also. In my case, I'm trying to restart a FSI simulation. Does any one have any suggestion?

I used the prev cfx res file both as the input file and initial condition. I attached how I did the setup for the mechanical side as a restart also.

Thanks in advance

All times are GMT -4. The time now is 01:18.