CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   PVM-RSH Problem (

Santhosh February 15, 2005 14:12

PVM-RSH Problem

I am able to run problems in parallel using CFX 5.7. But when I try to run the same/any problem in parallel with 5.7.1, it gives an error saying rsh failed and either pvm is running/or left files in tmp. PVM isnt running and the temp directory is empty. Any hints on why this occurs? I am using Win XP SP2 (firewall disabled).

Thanks, Santhosh

Glenn Horrocks February 15, 2005 17:02

Re: PVM-RSH Problem

This problem sometimes occurs using MPICH for windows, where the master does not clear the job from the slave nodes. The fix is pretty obvious - you go to the slave nodes and manually remove the jobs, then you should be OK to start again from the master node.

Keep in mind that you cannot mix CFX 5.7 and 5.7.1 in the cluster. Make sure all nodes are the same version, preferably the most current version.

Glenn Horrocks

Santhosh February 16, 2005 14:49

Re: PVM-RSH Problem

Thanks for the reply, but as I mentioned I did check the slaves. When I run any parallel problems on 5.7.1, the rsh fails, which is otherwise possible on 5.7 with the same hosts. The versions being the same on all nodes.


Kiddo February 18, 2005 21:48

Re: PVM-RSH Problem
Please check the RSH services is still "ON" even you set up the status "on" before. I encounterd this problem yesterday, and troubleshooted for a long time. At last, I check the RSH service is "STOP" on the slave machine (But no one turn it off !!!).

Santhosh February 19, 2005 09:19

Re: PVM-RSH Problem
RSH is on and working well with 5.7 on all nodes.

The message that appears is as follows:


Bound to Port 1018

Bound to Port 1019

Socket closed <?> after reading from:

The system cannot find the file specified.

Socket closed <?> after reading from //hostname//

Error in doing %PVM_ROOT%\lib\win32\pvmd3.exe ......

phase1<> RSH failed for host //hostname//


where //hostname// is the name of my slave.

Which file is it looking for?


MER February 21, 2005 12:32

Re: PVM-RSH Problem
Hi, I'm a new user with the PVM and I have encountred the same problem but in adding host to my network composed of two PCs.

I have received a message which can help you in your problem : he show me to indicate the path of the RSH service, with -DRSHCOMMAND in win32.conf file and to recompile the PVM. Try to use PVM_RSH in your variables envirnment in the control panel. If it works for you tel me that. thanks.

Santhosh February 22, 2005 11:38

Re: PVM-RSH Problem

The problem is solved, Please go through the CFX 5.7.1 Release notes for platform specific Issues (WIN). It states the error is due to the spaces in the installation root. Thanks to CFX tech support for finally pointing out the solution.


Joselito March 10, 2005 15:37

Re: PVM-RSH Problem
Hi, i have the same problem. What is win32.conf file in windows xp? Is there this file?

All times are GMT -4. The time now is 21:29.