CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > ANSYS > CFX

Unwanted "Primitive 2D" surfaces shown in CFx-PRE

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree3Likes
  • 2 Post By ghorrocks
  • 1 Post By ghorrocks

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   November 8, 2018, 20:17
Default Unwanted "Primitive 2D" surfaces shown in CFx-PRE
  #1
New Member
 
Daniel
Join Date: Nov 2018
Posts: 24
Rep Power: 4
themrdjj is on a distinguished road
When importing my airfoil mesh from ICEM into CFX-Pre, an unwanted surface appears at the trailing edge (see attachment).


How can I get rid of it?


It is not shown in the mesh in ICEM. I've tried deleting it in CFX-Pre but that doesn't work. I've also tried to deleting the "wall" boundary condition which seems to be connected to it ("Default Domain Default"), but that didn't work either. If I run the simulation right now, the surface shows up as a physical wall in the flow, which obviously destroys the results.
Attached Images
File Type: png primitive2D.PNG (15.6 KB, 40 views)
themrdjj is offline   Reply With Quote

Old   November 8, 2018, 23:48
Default
  #2
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 16,671
Rep Power: 130
ghorrocks is a jewel in the roughghorrocks is a jewel in the roughghorrocks is a jewel in the roughghorrocks is a jewel in the rough
You are getting that feature because there is a mismatched nodes in your mesh. Go back to ICEM and find the mismatched nodes and fix it at the source. ICEM has several tools to find mismatched and duplicate nodes in the "Edit Mesh" menu.

It is possible to put an interface on the mismatched faces to fix it but that is not a good solution, you don't want an interface right on a critical part of your flow model.
__________________
Note: I do not answer CFD questions by PM. CFD questions should be posted on the forum.
ghorrocks is offline   Reply With Quote

Old   November 9, 2018, 07:54
Default
  #3
New Member
 
Daniel
Join Date: Nov 2018
Posts: 24
Rep Power: 4
themrdjj is on a distinguished road
Thank you for your answer!


I tried running Edit Mesh -> Check Mesh with the standard options (I didn't see a "mismatched nodes" option). It only found 4 "Multiple edges", but they are not on that face but on the airfoil itself. Am I using the right tool?


Furthermore, I noticed that if I only show the mesh of the airfoil part, then I get this surface in the mesh (see attachment). I tried removing these elements manually, but they still appear in CFX Pre. Should these elements even be there?
Attached Images
File Type: png icem_problem.PNG (89.8 KB, 22 views)
themrdjj is offline   Reply With Quote

Old   November 9, 2018, 08:25
Default
  #4
Senior Member
 
Join Date: Jun 2009
Posts: 1,370
Rep Power: 25
Opaque will become famous soon enough
What is your concern with that surface?

Have you applied a boundary condition on it?

Does it show as part of the Default Boundary as a wall?
If it does, does it have a counter-part, i.e. there are two surface splitting two mesh volumes. If there are two sides, just create a general connection interface

If it does not, just ignore, the flow will go through it.
Opaque is offline   Reply With Quote

Old   November 9, 2018, 09:00
Default
  #5
New Member
 
Daniel
Join Date: Nov 2018
Posts: 24
Rep Power: 4
themrdjj is on a distinguished road
When I ran my first simulation, I got the results which you can see in the attachment, which are clearly wrong.

I haven't applied any boundary condition to it myself, but it shows as a "wall" boundary under "Default Domain Default". So I think that's the problem. How can I "ignore" this BC?

I don't know what a counter-part is. But as it seems to me there is only this one surface.
Attached Images
File Type: jpg streamlines_problem.jpg (82.0 KB, 23 views)
themrdjj is offline   Reply With Quote

Old   November 9, 2018, 09:08
Default
  #6
Senior Member
 
Join Date: Jun 2009
Posts: 1,370
Rep Power: 25
Opaque will become famous soon enough
What I thought.

Now I assume the surface must have a counter-part (another surface on the same location) because there is a volume on the other side. Otherwise, you need to go back to the mesher (ICEM you said), and find a way to split/duplicate the surface (unless you find a way to remove it)

Before going back to the meshing step, try to create a general connection domain interface, for Side 1 select the surface in question.

Then, for Side 2, scroll the list of available surface one at a time to see them in the viewer until you find which surface is its counterpart. If nothing found, back to meshing.

Hope it helps
Opaque is offline   Reply With Quote

Old   November 9, 2018, 09:41
Default
  #7
New Member
 
Daniel
Join Date: Nov 2018
Posts: 24
Rep Power: 4
themrdjj is on a distinguished road
When trying to establish the domain interface, the surface shows up as "Primitive 2D". In the list there are other parts such as "Primitive 2D A" but these are definitely other parts... (see attachment)


Back in ICEM I'm able to remove the surface by using Edit Mesh -> Delete Elements and then selecting all the elements in that surface. See the before and after images of the airfoil part in the attachment. However, when I import the mesh into CFX Pre, the surface still reappears again... Any idea why that could be?
Attached Images
File Type: png domain_interface.PNG (37.1 KB, 16 views)
File Type: png airfoil_after_removing.PNG (16.7 KB, 11 views)
File Type: png airfoil_before_removing.PNG (41.5 KB, 11 views)
themrdjj is offline   Reply With Quote

Old   November 9, 2018, 09:53
Default
  #8
Senior Member
 
Join Date: Jun 2009
Posts: 1,370
Rep Power: 25
Opaque will become famous soon enough
Not familiar with ICEM CFD details. However, you can try finding out how the Primitive 2D was created in CFX-Pre.

When importing the mesh, ICEM CFD, Advanced Options, Primitive Strategy, Select Derived.

The name of the split surface will know contain the name of the original surface
Opaque is offline   Reply With Quote

Old   November 9, 2018, 10:42
Default
  #9
New Member
 
Daniel
Join Date: Nov 2018
Posts: 24
Rep Power: 4
themrdjj is on a distinguished road
I tried doing "ICEM CFD, Advanced Options, Primitive Strategy, Select Derived" when importing into CFX-Pre. I did get two different surfaces this time, but one of the two surfaces was only half there... So now I get this simulation result, if I define the domain interface with those two surfaces (attachment). Pretty incorrect still.


Anyone got any other ideas how to fix this?
Attached Images
File Type: jpg streamlines_problem_2.jpg (58.6 KB, 18 views)
themrdjj is offline   Reply With Quote

Old   November 9, 2018, 11:31
Default
  #10
New Member
 
Daniel
Join Date: Nov 2018
Posts: 24
Rep Power: 4
themrdjj is on a distinguished road
Perhaps an interesting detail, just now I tried removing the surface and then directly running "Check Mesh" and then it shows "106 uncovered faces". If I say "fix" it recreates exactly that surface which I don't want.
themrdjj is offline   Reply With Quote

Old   November 9, 2018, 12:18
Default
  #11
New Member
 
Daniel
Join Date: Nov 2018
Posts: 24
Rep Power: 4
themrdjj is on a distinguished road
Also, this is the blocking. Maybe something is wrong here?
Attached Images
File Type: jpg blocking.jpg (62.3 KB, 18 views)
themrdjj is offline   Reply With Quote

Old   November 10, 2018, 00:10
Default
  #12
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 16,671
Rep Power: 130
ghorrocks is a jewel in the roughghorrocks is a jewel in the roughghorrocks is a jewel in the roughghorrocks is a jewel in the rough
Quote:
Back in ICEM I'm able to remove the surface ... However, when I import the mesh into CFX Pre, the surface still reappears again... Any idea why that could be?
In ICEM you cannot have a volume mesh without a surface mesh on the other faces. If you delete the surface mesh (but leave the volume mesh untouched) the surface mesh will just get regenerated.

You need to join the volume mesh up in these locations so it is not an uncovered volume mesh face and then ICEM will be happy. If you use the "check mesh" options it will identify whether the volume mesh is uncovered - but if you click "fix" it will just cap it with surfaces and that is not what you want. You need to delete the offending surface meshes and look at the nodes defining the volume mesh in that area and merge those nodes together. Then if you do "check mesh" again these faces should not get identified as uncovered faces. Then you know you have fixed the problem.
Shanaylla and themrdjj like this.
__________________
Note: I do not answer CFD questions by PM. CFD questions should be posted on the forum.
ghorrocks is offline   Reply With Quote

Old   November 10, 2018, 10:33
Default
  #13
New Member
 
Daniel
Join Date: Nov 2018
Posts: 24
Rep Power: 4
themrdjj is on a distinguished road
Thank you so much Glenn, that actually solved our problem! It works perfectly now! You might have saved my grade for the CFD course.


(In case anyone else has a similar problem: I first deleted the mesh surfaces, then I switched on the mesh volumes and selected all the corresponding nodes at once (using box selection), then I used merge by tolerance with a very small tolerance (0.01), since all nodes that remained are actually "double")
themrdjj is offline   Reply With Quote

Old   November 11, 2018, 03:13
Default
  #14
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 16,671
Rep Power: 130
ghorrocks is a jewel in the roughghorrocks is a jewel in the roughghorrocks is a jewel in the roughghorrocks is a jewel in the rough
Yup, that's how you do it. This is why ICEM is so powerful, you can do just about anything in it - but it has a big learning curve before you are proficient.
themrdjj likes this.
__________________
Note: I do not answer CFD questions by PM. CFD questions should be posted on the forum.
ghorrocks is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CFX pre error in assigning material to the domains madan CFX 1 February 18, 2015 01:55
Problems modeling CONTACT SURFACES with CFX Mesh MAldaz CFX 2 September 12, 2006 17:10
No.of Elements in ICEM and CFX Pre Manu CFX 1 August 25, 2006 07:20
CFX 5.7.1 PRE and solver won't start daniel CFX 1 January 20, 2006 10:09
CFX 5.7 pre Neser CFX 0 January 27, 2005 11:22


All times are GMT -4. The time now is 11:37.