CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   MPICH problem (CFX-5.7.1) (

Jesper April 12, 2005 07:34

MPICH problem (CFX-5.7.1)
Hi, I am facing difficulties trying to make the MPICH facility work on some machines:

I use the register user facility:

cfx5parallel -register-mpich-user

But get the folowing error are typing in username and password:

SetupCryptoClient:CryptAquireContex(...) failed, error: -2146893788 Error text: The profile for the user is a temporary profile. Error: Unable to setup the encryption service

I have successfully installed the MPICH facility on some older machines with the same username and password, but these new ones are making trouble. The username I use is a domain username, and all the computers are on the same domain, and the user has full administrator and domain administrator rights on all machines.

Has anyone faced the same troubles as me? I have currently installed the PVM facility instead of MPICH, but I don't find it as efficient as the MPICH.

Regards Jesper

Glenn Horrocks April 12, 2005 18:46

Re: MPICH problem (CFX-5.7.1)
Hi Jesper,

What operating system are you using?

Glenn Horrocks

Jesper April 13, 2005 03:00

Re: MPICH problem (CFX-5.7.1)
Hi Glenn, I am using Win2000, updated with both win2000 and CFX-5.7.1 service packs. Best Regards Jesper

deLuther April 13, 2005 12:49

Re: MPICH problem (CFX-5.7.1)
Maybe better to setup local accounts identical on all machines. And register MPICH user to this account. This worked on win2000 and 5.7.1. But in particular case it can be more complicated.

Glenn Horrocks April 13, 2005 18:33

Re: MPICH problem (CFX-5.7.1)

Also make sure when you register the MPICH account you are also logged on under that user. It gives some weird errors if you don't.

Regards, Glenn Horrocks

Jesper April 14, 2005 08:16

Re: MPICH problem (CFX-5.7.1)
Hi deLuther. Yes you are right. It seems to be working that way. Maybe I should not bother more then. It just puzzles me that the domain user works on some machine and not on others, even though they should be equally setup. But I think I will stick to the local user, now that it works

Jesper April 14, 2005 08:22

Re: MPICH problem (CFX-5.7.1)
You are right about that, and I actually got the same error message as indicated in the original post (registering MPICH with the domain user), even though I am positive that I was logged on to the pc with the domain user. There is something weird going on that I can not figure out. But if you have seen my previous post, the problem is sorted out by using a local user on the machines. So, I think I better stick to that:)

Regards Jesper

deLuther April 16, 2005 05:04

Re: MPICH problem (CFX-5.7.1)
I our case we use local user with restricted rights because domain user must change password every 2 weeks. But make that on several machines is, of course, headache. I`m glad that our`s recipie helps.

All times are GMT -4. The time now is 18:34.