CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   ERROR #001100279 has occurred in subroutine ErrAct (

Carl July 15, 2005 13:53

ERROR #001100279 has occurred in subroutine ErrAct
Dear all, I am facing an crash error trying to solve a rotating disc with channel. The problem is in steady state with temperature on the rotating walls. I am using openings and the entire domain is 2.5 larger (radially) than the disc and 5 taller. I ran one solution using ambient temperature conditions and 100 RPM. It ran nicely. Then I set the temperature boundary conditions, and I ran it at 100RPM again. It also ran without problems up to 100 iterations (with 1e-3 RMS in u (radial) vel. component). Now I increased the velocity to 150 RPM and it crashes at the 5 iteration.

| ERROR #001100279 has occurred in subroutine ErrAction. | | Message: | | Floating point exception: Type Unknown


+--------------------------------------------------------------------+ | Writing crash recovery file | +--------------------------------------------------------------------+

Details of error:- ---------------- Error detected by routine POPDIR CRESLT = ILEG

+--------------------------------------------------------------------+ | An error has occurred in cfx5solve: | | | | The CFX-5 solver exited with return code 1. No results file has | | been created. | +--------------------------------------------------------------------+

End of solution stage.

+--------------------------------------------------------------------+ | An error has occurred in cfx5solve: | | | | Error reported by IO module: iif_set_lock: file | | /SPACE/CFX/CHANNEL/RUN/10DEG_1ROT/150RPM/10DEG_1_150RPM_002.dir/c- | | rash is currently locked for writing, and cannot be locked for | | read access. Either another program is using this file, or the | | lock file | | /SPACE/CFX/CHANNEL/RUN/10DEG_1ROT/150RPM/10DEG_1_150RPM_002.dir/c- | | rash.lck is bad. | +--------------------------------------------------------------------+

+--------------------------------------------------------------------+ | An error has occurred in cfx5solve: | | | | Error reported by IO module: iocnt: open the primary file failed | +--------------------------------------------------------------------+

+--------------------------------------------------------------------+ | An error has occurred in cfx5solve: | | | | Error from IO module while opening | | /SPACE/CFX/CHANNEL/RUN/10DEG_1ROT/150RPM/10DEG_1_150RPM_002.dir/c- | | rash: | | | | "iocnt: open the primary file failed" | | | | IO_LOCKED(21): File is locked. Remove the lock (lck) file if this | | shouldn't be the case

I haven't got any idea where the error may come from... I revised the results for the 100 RPM and they look quite realistic... high flow in the backplate of the channel, some reverse flow in the leading plate, etc etc.

I suspect it has to do with the numerical solution since it is a FLOATING POINT EXCEPTION (Type unknown),... but I can not understand the 2nd and 3rd error descriptions... Any help is welcomed.

FPE July 15, 2005 15:24

Re: ERROR #001100279 has occurred in subroutine Er
Anything after a floating point exception is unpredictable.. It seems the flow solver was trying to write a recovery file for diagnostics and it fail at that as well.

I would try setting the Output Residuals option to All, and the maximum number of iterations to 1 before the failure ocurred. See in CFX-Post what the flow looks like.. May be it is something wrong already..

Have you checked the output file diagnostics before the failure. Perhaps the solver was failing already..

You said you have increased the rotating speed. Did you decreased the time step accordingly? The faster it spins, the smaller the timestep you need.

Hope this helps..

Carl July 16, 2005 14:39

Re: ERROR #001100279 has occurred in subroutine Er
Thanks FPE, I am giving a 2nd look and I noticed that velocity field before the crahed iteration is very un-real. I had chosen autotimescale first, so I have decreased it now (physical)... I'll see.

All times are GMT -4. The time now is 11:39.