CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Multiphase reaction Solver Error (

hagupta April 4, 2006 06:59

Multiphase reaction Solver Error
My problem consists of a "Reacting Mixture(with 4 gases)",a solid (MultiPhase-Eulerian) Out of these, the solid and a gas are formed after the reaction.

I am finding it really difficult trying to obtain the results.

I get this error and the run stops.

For all the 4 gases and the solid, I have entered the Cp values as a function(User function) of temp. These Cp values, ref entropy, ref enthalpy have been taken from the NASA thermobuild.

As you can see in the above link, I have tried increasing the Newton Iteration Limit to 200, but of no avail. I have also increased the pressure limits for each gas and the solid.

How do I debug this?

opaque April 4, 2006 09:14

Re: Multiphase reaction Solver Error
Dear Hagupta,

Have you tried the same simulation with constant properties already provided?

Either your properties are not thermodynamically consistent among themselves? Your time tstep may be too large...

You may need to talk to CFX help desk..

Good luck, Opaque..

hagupta April 4, 2006 10:11

Re: Multiphase reaction Solver Error
Thank you, Opaque

Only 2 of the materials that I use are predefined in CFX. So, I have not yet tried the simulation with constant properties already provided.

1) So, should I try the simulation with 3 user materials and 2 CFX materials OR try a similar reaction (1 solid and 4 gases) taking all 5 CFX materials?

2) The auto timestep value was around 2.5e-5. The least timestep I have tried is 1e-5. Should I try reducing this to 1e-7 or still lower?

If the above 2 steps do not lead me to the solution, I think I will talk to the CFX help desk.

hagupta April 8, 2006 09:43

Re: Multiphase reaction Solver Error
I tried with reduced timesteps the following 2 runs:

1) Single Phase with const prop. After several iterations(much more than what it used to be earlier) the solver crashed with "Floating point exception" error. Just before this error, I got "The Mach number exceeds....." error.

2) Multiphase with the value of "Minimum volume fraction for Mixture/Solid fluid pair set to the minimum possible(1e-15). This too crashed with "floating point exception-division by zero" error.

I was searching for the possible causes for this error and found a coarse mesh as one of the possible causes. Both of the above 2 setups had the same very coarse mesh. I have been using the coarse mesh to save time since I run it on a single processor.

So, how do I proceed further? Interpolate the results from the last saved .bak file onto a finer mesh and continue?

Regards, hagupta

All times are GMT -4. The time now is 22:07.