CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Laminar non-premixed flame (

Paul January 12, 2007 05:48

Laminar non-premixed flame

I have tough time here to simulate a laminar non-premixed methane-air flame. I use the Finite Rate Chemistry model for this purpose.I find that it always over-predicts the temperature giving values only between 5000 - 6000 K. I am initializing the domain temperature to about 1200 K. Can anyone throw light on where I am making a mistake? The same mesh with increased flow rates and on usage of Eddy Dissipation model gives satisfactory results

Regards, Paul

matej January 14, 2007 08:23

Re: Laminar non-premixed flame
have a look into FAQ section here:

there's an answer. have a good fun


Paul January 15, 2007 01:14

Re: Laminar non-premixed flame
Hi Matej,

I am using CFX 10.0. Does the "stiff chemistry = t" option exist in this version? Atleast it doesnt appear in the GUI(Create>Expert Objects>Expert Parameters) which has some similar options. Even typing "stiff chemsitry" in the CFX-Pre Help doesnt throw any results. But still i tried some thing.I went to Tools>Command Editor, copied these commands


stiff chemistry = t


Then I clicked on Process, saved the Pre file and started the run. But i got the following error: "Error: Sub-object 'EXPERT PARAMETERS' is not allowed in /"

Any suggestions?



Paul January 16, 2007 01:21

Re: Laminar non-premixed flame
Hi Matej, Even i tried doing what Paul did, but with no effect It would be nice if you tell us how to do that in detail

bye, Husain

matej January 18, 2007 07:50

Re: Laminar non-premixed flame

OK, you will not find this in any help file in CFX, it is somehow not documented publicly.

if you would have a look in your *.def file in text file, which you can do with a cfx5cmds commands (I do not know how it works in windows, sorry) you would see, that the definition file is structured. Every commands has its unique place, which in case of EXPERT PARAMETER is under the FLOW tree. If you're unsure how to do it, do it with a "cfx5cmds -edit -def *.def" command and add the EXPERT SECTION as described in the manual. After you create the expert section, you may check it in the text file how and where it is written and you may add things like 'stiff chemistry = t' or whatever Cfx wishes to swallow.

hope this helps,

have fun


Paul January 19, 2007 00:28

Re: Laminar non-premixed flame
Thanks a lot Matej,

It really works. The temperatures now have dripped to 2000 K . I couldnt exactly do what you said because I am more familiar with GUI/Windows usage. I did the same thing using GUI. I am really surprised why such a crucial thing has not been documented.

For those of you who are troubled by high combustion temperatures by using Finite Rate Chemistry Model, here is the fix in CFX 10.0

1. In the Solver Manager, before you click "Start Run", Go to Tools>Edit definition file.

2. Click Add Parameter if you already have an Expert Parameter Section (otherwise create one)

3. The option "stiff chemistry" is not available by default. Just type in the box "stiff chemistry" and assign a value "t". Save the file and exit.

4. Start the run.

Thanks once again Matej



All times are GMT -4. The time now is 12:57.