CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   QUICK-Discretization Scheme (

Fonzie February 8, 2007 10:36

QUICK-Discretization Scheme
Hello everybody,

I have an issue concerning the QUICK-discretization scheme. I have performed two runs on a pretty coarse grid (about 600k element, 100k nodes, no special boundary layer resolution (that is pretty hight y+) and no densities in the wake regions) that was generated with ICEMCFD. I conducted two runs with the blend factor at sbf=0.75 and sbf=1 using the first run as initial solution for the second run. After that, I have tried to use the QUICK-scheme with the sbf=1-solution as the initial guess. With that configuration the solver crashed immediately, saying:

ERROR #004100018 has occurred in subroutine FINMES. Message: Fatal overflow in linear solver.

After that, I tried without an initial solution. This time the solver crashed after the first outer loop, saying:

A wall has been placed at portion(s) of an OUTLET boundary condition (at 59.7% of the faces, 59.7% of the area) to prevent fluid from flowing into the domain. The boundary condition name is: OUT. The fluid name is: Air Ideal Gas. If this situation persists, consider switching to an Opening type boundary condition instead.

****** Notice ****** The maximum Mach number currently is 5.930E+03. If this message persists and you experience robustness problems,consider setting the expert parameter 'max continuity loops' to 2.

ERROR #004100018 has occurred in subroutine FINMES. Message: Fatal overflow in linear solver.

Did anyone ever have the same or similar problem an might know what the problem is?

Regards and thank you Andreas

Glenn Horrocks February 8, 2007 17:39

Re: QUICK-Discretization Scheme

A big problem with QUICK is that it is not very numerically stable, and I think that is exactly what you are experiencing. This is especially important for sonic flows - QUICK is terrible for sonic flows. In my experience QUICK is only good for low Mach number flows with very even grid spacing (or preferably constant grid spacing).

I strongly recommend you use the High resolution differencing scheme as it is much more robust for sonic flows. There is a loss of formal accuracy to second order in general and first order at strong gradients but QUICK will have major boundedness and other stability problems so is unlikely to be more accurate.

Glenn Horrocks

Fonzie February 9, 2007 07:11

Re: QUICK-Discretization Scheme
Hey Glenn,

thanks for your advice. One further issue with my flow - actually it is not sonic at all! I have a frees stream velocity of about 36 m/sec and maximum velocities of about 45 m/sec around my article. So the CFX-warning for my maximum Mach number confuses me even more. So I suppose that something is going totally wrong with the QUICK scheme... However I have no idea what it could be.


Glenn Horrocks February 10, 2007 00:46

Re: QUICK-Discretization Scheme

If the flow is not high speed but it is giving warning messages about supersonic flows then something is seriously wrong. Either your simulation is diverging in a big way (go to high resolution differencing, it is much more stable) or your simulation setup is wrong.

Glenn Horrocks

Reza_computational May 24, 2010 12:34

Hello everybody
I have encountered the error (some faces have been replaced with walls to prevent fluid flowing out or into the boundary) once i was solving flow in centrifugal compressor with cfx and QUICK scheme...

ghorrocks May 24, 2010 18:25

It is not an error. It is a warning.

It just means that the inlet or outlet has reverse flow and it has stopped the reverse flow using artificial walls. This can occur when you use QUICK because it is allows resolution for finer features than the default scheme.

feizaghaee May 29, 2010 07:21

how can i use QUICK scheme?

ghorrocks May 29, 2010 17:52

You have to select it using CEL. Set up a run using some other differencign scheme and replace the entry with QUICK.

feizaghaee May 30, 2010 02:51

where can i read description of setting up QUICK scheme

ghorrocks May 30, 2010 07:29

Not sure it is documented. To set it up you need to edit the CCL. Find the Spatial differencing key and change whatever is there (probably upwind or hybrid by default) and in a text editor change it to "QUICK". Reload the CCL and you will be using QUICK.

feizaghaee May 31, 2010 15:08

thanks in advance

All times are GMT -4. The time now is 23:18.