CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   CFX not releasing licenses (

Glenn Horrocks August 29, 2007 19:03

CFX not releasing licenses
Hi all,

This is a problem which has been bugging me (no pun intended) for a while and it killed some jobs last night so hopefully somebody has some ideas about it. I have discussed this with my local support office but so far the fix eludes me.

When I do a batch file to script a number of CFX jobs together it occasionally fails to release a license in the previous run and crashes the next run as a license is not available. The previous run had stopped and finished successfully so there is no obvious reason why it failed to release the license. Also there was no other users of CFX on the network at that time so nobody else grabbed the license. I can also assure you the license server was up and the network was functioning - for example all other licenses except the parallel licenses were released.

I have recently installed CFX SP1 (on top of update 1) but I have had the problem for ages (at least a year, on and off) so it is not caused by the service pack or update on CFX11.

Is there any known issues with CFX releasing licenses? Is there something I can set to force CFX to release its licenses when it finishes? Or is it something on the license server? Any tips would be appreciated.

Glenn Horrocks

longbow August 30, 2007 08:46

Re: CFX not releasing licenses
Have you tried to put a delay of launching new job after one is done, for example, 5 or 10 minutes?

Glenn Horrocks August 30, 2007 18:28

Re: CFX not releasing licenses

A little more information:

It is only the parallel licenses which don't release, the solver and solver options (eg multiphase) options release OK.

When they don't release they stay stuck - you have to reset the license server to release them. They do not release themselves after a period of time.

I have read the flexlm manual but it is pretty hard work to make sense of. I think there is an option to make a license server re-check a license every few minutes. I might give that a try. Any other ideas are welcome!

Glenn Horrocks

Patrick August 31, 2007 04:58

Re: CFX not releasing licenses
Hi Glenn,

As we installed the SP1 a while ago we were confronted with similar problems. Check out of licences worked except the parallel (and only on linux machines). Our support guy found out, that the sequence of the license check out is not in the correct order.

With the Solver start command "-P 335" everything works now. But this is just a workaround and I hope this bug will be fixed soon.



Bian August 31, 2007 12:15

Re: CFX not releasing licenses
I do not have the exact experience. But, frequently, if the program crashes (solver, Pre, Post, or others), I have to restart the license manager to release licenses it still holds.

Glenn Horrocks August 31, 2007 18:37

Re: CFX not releasing licenses
Hi Patrick,

Thanks for that tip, I will try it shortly. I assume you it is a flag on the command line, such as "cfx5solve -def XXX.def -P 335". Is this correct?

Glenn Horrocks

Patrick September 4, 2007 08:52

Re: CFX not releasing licenses
Hi Glenn,

Should also work in the command line. But you can also write the arguments in the GUI of the solver with "Define Run" in the "Solver"-tab in the "Solver Argument"-Field.

Regards Patrick

All times are GMT -4. The time now is 06:39.