CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   memory allocation error (

MAB August 5, 2008 06:37

memory allocation error
I keen getting the following message when i try to run solver. While there is about 50 GB storage available on the disk. what should I do to overcome this problem thank

*** Run-time memory allocation error *** | | Not enough free memory is currently available on the system. | | Could not allocate requested memory - exiting!

Rogerio Fernandes Brito August 5, 2008 06:50

Re: memory allocation error
how much do you have of memory RAM? I do some kind of simulations and my files are about 80 GB (trn files) and i donīt have this problem. I have only 8 GB of RAM.

MAB August 5, 2008 07:04

Re: memory allocation error
Hi Rogerio. it is about 4GB RAM. is it because of RAM that I am getting this message. well it is the same problem which i sent you yesterday for meshing. I have done meshing somehow. but now its giving the memory error.

MAB August 5, 2008 07:13

Re: memory allocation error
also the number of tetra is about 60,00000 :(

Rogerio Fernandes Brito August 5, 2008 07:13

Re: memory allocation error
increase this memory allocation. When i worked with a Athlon PC XP with only 512 MB of RAM, i did it sometimes and it did work out.

Rogerio Fernandes Brito August 5, 2008 07:15

Re: memory allocation error
6,000,000.00 of elements?

If it is, you MUST increase your memory (RAM) up to 8 GB!

John August 5, 2008 09:11

Re: memory allocation error
I'm not sure if this is specifically a system specification problem but it sounds to me like you need to allot more memory for the solver and/or partitioner. Try setting a factor 1.2-2.0 for the partioner and see if that helps.

You might also try setting the expert parameter "topology estimate factor" to a factor of 1.2 or so.

MAB August 5, 2008 09:42

Re: memory allocation error
hi where I can find this partitioner settings. thanks

John August 5, 2008 09:53

Re: memory allocation error
If you're running CFX locally through the Solver Manager you'll find input boxes for memory overrides on the Partitioner and Solver tabs. If you submit the job over a network with a script you can set "-sizepar" and "-s" where -sizepar is the partitioner memory override factor and -s is the solver memory override factor.

MAB August 5, 2008 10:10

Re: memory allocation error
I am in CFX pre and I cant find partitioner option. i know the expert parameter

John August 5, 2008 10:12

Re: memory allocation error
The partitioner memory allocation option is set in the Solver Manager.

Matthias August 12, 2008 11:09

Re: memory allocation error
isnīt it like there is not enough free RAM for the Solver to run the simulation? The solver tries to allocate enough memory to store the values; if there isnīt enough... there is "not enough free memory available". I often could get rid of this by allocating less then the 100 percent... like 90. You need approximately 1GB for 500.000 hexaelements or about 1.5mio tetra-elements . Hope that helps.

MAB August 12, 2008 11:57

Re: memory allocation error
thanks. how can i change this option fom 100% to 90.???

Matthias August 13, 2008 08:32

Re: memory allocation error
From the Solver-GUI

Define Run-->"Show Advanced Controls"

Solver Tab--> Solver Memory,Memory Alloc Factor =0.9

lynnmaeu December 27, 2014 20:26

Matthias said

From the Solver-GUI

Define Run-->"Show Advanced Controls"

Solver Tab--> Solver Memory,Memory Alloc Factor =0.9

It worked completely

thanks you very much, Matthias

Martin_Sz December 30, 2014 06:38

try to increase allocation memory factor to 10 on the three options on solver
second question is how many processors/cores /threads do you have ??
Try to divide your simulation on all processors/cores/threads

ghorrocks December 30, 2014 21:59

The error message says "not enough free memory available". This is not a memory allocation problem so the memory allocation factor will not help it. It has simply run out of RAM so it needs more memory. If it was on a 32 bit system it may have maxxed out the 32 bit limit so needs a 64 bit OS and solver.

All times are GMT -4. The time now is 06:32.