CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Memory error? (

Young September 30, 2008 00:28

Memory error?

I have tried to run a cetain heat exchanger.

but I have stuk in the memory allocation error.

Look this error.

-------------------------------------------------------------------+ | Memory Allocated for Run (Actual usage may be less) | +--------------------------------------------------------------------+

Data Type Kwords Words/Node Words/Elem Kbytes Bytes/Node

Real 358015.0 930.81 211.53 1398496.0 3723.24 Integer 128450.2 333.96 75.89 501758.5 1335.84 Character 2335.3 6.07 1.38 2280.6 6.07 Logical 52.0 0.14 0.03 203.1 0.54 Double 486.4 1.26 0.29 3800.0 10.12

+--------------------------------------------------------------------+ | ERROR #001100279 has occurred in subroutine ErrAction. | | Message: | | *** Run-time memory allocation error *** | | Not enough free memory is currently available on the system. | | Could not allocate requested memory - exiting! | | | | | | |

CFX-Solver needs nearly 1.9G memory.

But Physical memory of my computer(pen-4, XP) is 3G and its avaiable memory is upto 2.4G when I run the cfx file.

What makes it happen? How do I get over here?

Thank you for your attention.

Sans September 30, 2008 03:42

Re: Memory error?

Refer to the discussion over here...

ReeKo September 30, 2008 08:06

Re: Memory error?
Hi Young,

Glad to help you if I can, don't know exactly how windows (I guess it's 32bit if you have such a problem) deals with memory allocation but I learnt a couple of thing about that:

1) Windows doesn't allow a process involving more than 2GB physical ram. This is a theoretical limit since the effective one it's 1,5~1,8 gb depending on process you're running (I mean on task manager) and on your system. Anyway your simulation, as my case was, it's surely beyond this limit.

--> Try to enable /3GB switch on you boot.ini as you can read here ( You find it @ Start --> Control Panel --> System --> Advanced --> Startup (3rd tab) --> System startup / modify. This operation it's also suggested by ANSYS troubleshooting

2) As Glenn Horrocks says in my previous discussion:

"In Windows 32 bit while the theoretical maximum process size is 2GB the memory is always fragmented so a process cannot grab a 2GB contiguous chunk of memory. So the actual maximum size of memory you can grab depends on whatever other stuff is loaded on the machine. For instance you will get a bit bigger chunk on a freshly booted machine compared to one which has checked email, done some web surfing etc - even if the software has subsequently been closed.

The maximum size of memory a process can grab is 1.2-1.7GB. So your 1.5GB job is right in this range, so sometimes it will work and sometimes it won't. You need to go parallel or go to 64 bit."

--> That's true. The problem is to get continous memory chuncks at simulation startup so basically you need to reboot before go. If this has no effect try to download a freeware ram defragmenter, as i did, and execute it just before simulation, there are plenty of them around.

This worked for me. If you have problems again you have only to change OS, you'd have to try linux for example, and obviously own the related software version.

Bye, tell if it works ReeKo

Young September 30, 2008 11:33

Re: Memory error?

Thanks Sans Reeko.

I appreciate your valuable helps.

All times are GMT -4. The time now is 15:55.