CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   turbo problem (

Toralf October 28, 2008 08:52

turbo problem
hi, after simulation of a turboproblem I would like start the turbotool in cfx-post. after intialization it comes following message: "WARNING failed to initialize component 'component 1' in domain 'rotor' for conversion type 'cartesian to turbo'. I have defindes every part and domain. who can give an advice? thanks.

CycLone October 28, 2008 09:08

Re: turbo problem
Turbo initialization only works for bladed or axisymmetric components, i.e. those that circumferential swept hub, shroud, inlet and outlet locations. If component 1, in your case, is a non turbo component (i.e. an inlet scroll upstream or a volute downstream), it cannot be initialized. Just uncheck the box next to it and Post won't try initializing it.

If it is a turbo component, make sure the hub, shroud, blade, etc. regions are located properly. Post has a pre-defined list of region names it uses to identify these, but you can manually locate them as well.


sam October 29, 2008 13:15

Re: turbo problem
Are you using meshes created in turbogrid?

blackbody April 15, 2010 19:17

i'm having the same probelem!!!

I want to analyse a 1.5 stage axial turbine (which I created with TurboGrid) in the CFD-Post Turbo Mode.
When I want to "Initialize All Components" I get the same error as written above...

I think I set everything correctly:
I created a Stator1 mesh, a Rotor1 mesh and a Stator2 mesh (one blade each).
Than in CFX i used the Turbomachinery tool to set up the whole arrangement.

To get a 2:3:2 ratio for Stator1/Rotor1/Stator2 i applied following:

"Passaged and Alignment" -> "Passages to Model" -> 2, 3, 2 respectively.

Why is that error and what can I do since I really have to use this Turbo Mode in CFD-Post.
Thank you guys very much for your help in advance.

Bdew8556 August 16, 2016 03:34

Im having a similar issue.

Im trying to generate compressor speed lines, so im setting input and output parameters and varying the mass flow with constant rpm to find output pressure.

Again an issue with initialization.

Did anyone figure this out?

spl September 10, 2016 14:07

Have you tried using the manual initialization? If you have named the necessary mesh regions you should be able to select the various parts and it should work fine.

All times are GMT -4. The time now is 22:46.