CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Guide setup PVM CFX (

painterwolf May 15, 2009 19:21

Guide setup PVM CFX
Hi all,
I have two PC and I would like run my solutions in parallel. Can I have a complete guide for to do this? You consider I know nothing in this argument.
Thanks very much

painterwolf May 16, 2009 07:06

Can anyone talk me about my problem? Please. Does exist a guide for this?

sans May 18, 2009 08:20

Its quite simple; just follow the procedure given in the help files.
CFX Help-->Installation and Licensing Documentation-->Configuring ANSYS CFX Parallel


chiragcool13 May 18, 2009 08:29

Swirl Angle in CFX
Dear Friends I am new in CFX and in CFD.

I want to do CFD of CW pump. I want to find out swirl angle by using post processing in CFx. Kindly guide me how to find swirl angle in CFX

Rui May 18, 2009 11:07

New to CFX?
Start by doing all the tutorials.

painterwolf May 20, 2009 14:10

I edited my hosts.ccl in this way, I copied parameters by other PC:

# ANSYS CFX Host Definition File
# Automatically created
# by C:\Program Files\Ansys Inc\v110\CFX\bin\perllib\
# at Wed Apr 1 20:32:56 2009.

HOST DEFINITION: mirkoca2693f8e
Remote Host Name = MIRKO-CA2693F8E
Installation Root = C:\Program Files\Ansys Inc\v%v\CFX
Host Architecture String = amd_opteron.sse2_winnt
END # HOST DEFINITION mirkoca2693f8e
Installation Root = C:\Programmi\Ansys Inc\v%v\CFX
Host Architecture String = intel_xeon64.sse2_winnt5.1

When I am in solver I add remote host and I have my dual cor with 2 partitions and my PC4 with 1 partition.

When I click start I have two errors. I show you which errors I have:

-Host name lookup failed for host pc4-

-Attempt to monitor run in progress failed. The supplied run directory name is invalid or does not exist

C://Documents and settings//Administrator//Desktop//calcolo parallelo//PREGRIGLIAROTONDAVEL1_001.dir

I think I have problems with rsh and another problem I don't know

P:S: I don't know if it's important but I use windows xp 64 bit in dual core pc and xp 32bit in PC4. Because I hadn't got RSH, I installed RSH beta version that is situated in this page:
Now, I installed RSH but I don't know how I have to setup it

sans May 21, 2009 02:41

You dont need to use a third party rsh for CFX. I would suggest remove the installed rsh and use the one provided by CFX.
The entire step by step procedure is give in the documentation.
Installation and Licensing Documentation-->Configuring ANSYS CFX Parallel--> 2.3. Installing the rsh Service

Once done, check if rsh is working by using rsh <machine name> cmd /c echo working. If its working it should echo back 'working'. Before that just try to see if you have connectivity between your m/cs using the ping command. Also you could disable (temporary) windows firewall to see if that would help.


painterwolf May 21, 2009 18:23

I followed all instructions and now my PCS can communicate but when I launch solver solution I have this error.

The solver executable c:\.............................\solver-pvm.exe on host PC4 could not be found, or is not readable. Check that the executable is readable by the user running the rsh service.

I have installed CFX in PC4, why my solver-pvm.exe is not readable?

ghorrocks May 21, 2009 19:30


From memory this is a V11 bug and a fix was released to address it. Talk to your CFX support person to get the fix. The current version is V12 so you should go to the current version anyway.

Glenn Horrocks

painterwolf May 22, 2009 14:42

Ok but who has CFX v11 can't run a parallel solution?
Is there another solution?

sans May 23, 2009 01:44

Can you try changing your Installation Root to "C:\Progra~1\ANSYSI~1\v%v\CFX". I have observed that spaces in the installation root do create problems. Restart and check if it runs.


painterwolf May 23, 2009 21:16

I changed installation path but don't work.
I readed windows xp had problem with RSH in SP2 and theese problems are solved in SP3. So I upgrade my OS to SP3 but don't work.
Always the same error:
| An error has occurred in cfx5solve: |
| |
| The solver executable |
| C:\Programmi\Ansys~Inc\v110\CFX\bin\winnt\solver-pvm.exe could not |
| be found, or is not readable. |

| An error has occurred in cfx5solve: |
| |
| The solver executable |
| C:\PROGRA~1\Ansys~Inc\v110\CFX\bin\winnt\solver-pvm.exe on host |
| PC4 could not be found, or is not readable. Check that the |
| executable is readable by the user running the rsh service. |

The last chanche is CFX V12.
In next days maybe I'll have it and I'll try if work.
Other ideas?

ghorrocks May 24, 2009 19:47


I will say it again - the failure to find the solver executable for V11 on newer CPUs is a known bug and requires a fix from ANSYS to get it working. You are wasting your time if you do anything but contact ANSYS to get the fix, that is the only way.

V12 does not have the bug so should also be OK.

Glenn Horrocks

All times are GMT -4. The time now is 16:29.