CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   CFX12 crashes if trying to open a *.def File (

peterputer1 September 25, 2009 06:02

CFX12 crashes if trying to open a *.def File

i ve a problem with CFX12 Pre. I just installed it and tried to open an old definition file. Then i get the following error msg:

Severe Error
Operation failed. (System exception: Token name resolves to parent type: FLUID)
Unknown quantity type: Relative Molecular Mass

Afterwards CFX Pre just crashs. I opened several other definition files without any problem (still the warning about the unknown quantity type was there, but at least it runs), so CFX Pre12 is working, but just not for the definition file im currently working with :/
Anybody has some hints?


ghorrocks September 25, 2009 06:51

First import the mesh (and only the mesh) into CFX-Pre. The use cfx5cmds to extract the CCL from the old def file, then import that CCL into CFX-Pre.

peterputer1 November 6, 2009 07:10


it is not allowed in CFX-Pre 12 to call a Domain "FLUID" anymore with capital letters, if i rename it to Fluid it works fine.


ghorrocks November 7, 2009 06:35

Wow, that's a weird error. Can you report it to CFX Support and hopefully they can fix it for the next release?

martinD July 28, 2010 05:12

I have the same problem with CFX-post. The error is shown when the program is started, before any *.res file is loaded.

mvoss July 28, 2010 06:05

try to import the def-file not load it with CFX-Pre.
I think it is because of the newer naming in the materials which comes with CFX12.


martinD July 28, 2010 07:05

I have tried, but it does not work. actually i don not realy know what you mean. Import option in post supports only csv files.

mvoss July 28, 2010 07:10

i suppose you want to open some def. res. file from cfx11, right?
if itīs like that, you have to import the files into the WB instead of opening them in the appropriate program. saying so, because i know it from this missing molar mass entry from your first post.


martinD July 28, 2010 07:28

Yes, you are right. actually I have created the simulation in CFX-pre-v11, usually we are using solver v11 and also post, but in this case I have used another computer with version 12.
That probably means that I have to create another .def file with import and than restart simulation.

mvoss July 28, 2010 07:32

i guess that WB can handle "old" datasets, that would be the workaround.
maybe you can restart from the res. and only doing one iteration ending up in an "new" res file....


martinD July 28, 2010 07:43


All times are GMT -4. The time now is 03:47.