CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   pressure error with particle tracking (

dsmith October 10, 2009 11:29

pressure error with particle tracking
Hi There,

I have been trying to run a simulation with the particle tracking model and having problems. the model consists of two domains; a main flow domain with dust particles and an extraction domain removing particles.

The model was working fine initially but upon refining the mesh (I used the mesh adaptation tool in CFX-Pre for each domain individually and combined them again) Solver crashes and terminates the following

The mesh refined was initially alot coarser then the mesh that was working, which was "average" everywhere.

Fatal error generated in gKElEl
Message :- Some boundary elements may be missing BCs.

gKElEl called by :- SU_KELEL

| Writing crash recovery file |
Error in subroutine CAL_VAR_ICS :
Initial conditions for Pressure could not be calculated.
GETVAR originally called by subroutine GET_MFLOIP_ZIF

| An error has occurred in cfx5solve: |
| |
| The ANSYS CFX solver exited with return code 1. No results file |
| has been created. |

End of solution stage.

| Warning! |
| |
| The ANSYS CFX Solver has written a crash recovery file. This file |
| has been saved as C:\Temp\Dane CFD Research\combined_001.res.err |
| and may be an aid to diagnosing the problem or restarting the run. |
| More details should be available in the solver output section of |
| the output file. Note that a lock file was left for the crash |
| file when the solver exited, and so it is probably incomplete. |

| The following user files have been saved in the directory |
| C:\Temp\Dane CFD Research\combined_001: |
| |
| lsprst7.dll, lsprst7.tgz, mon |

This run of the ANSYS CFX Solver has finished.

However, if particle tracking is turned off it solves fine (without the error message). Does anyone know why this is?

I have a suspicion that it is because my mesh ranges from being fine to rather coarse in regions. I have a maximum aspect ratio of approx 600 and maximum expansion factor of 200.

Are then any ways around this? please note that the undergrad pc's I have access to are probably worse than my personal laptop. So, introducing more nodes will result in a "memory allocation error" as I'm right at the limit currently and I'm sure the same will happen if I set up double precision.

Cheers in advance for the help!!

ghorrocks October 11, 2009 05:16

Clearly it is not happy using a mesh refined as you did in particle tracking. This sounds weird, it is probably a bug. The obvious work-around is to simply re-mesh it with your normal meshing software. Is there any reason you can't do this?

All times are GMT -4. The time now is 13:51.