CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   CFX (https://www.cfd-online.com/Forums/cfx/)
-   -   Error message CFX Solver (https://www.cfd-online.com/Forums/cfx/69995-error-message-cfx-solver.html)

Fatnes November 11, 2009 09:07

Error message CFX Solver
 
Hi.

The solver stopped my simulations after appr. 15 timesteps given the following error message:

An error has occurred in cfx5solve: |
| |
| The ANSYS CFX solver could not be started, or exited with return |
| code 255: . No results file has been created.

Does anyone know what "return code 255" mean?

nellio75 November 19, 2009 05:38

Hello Fatnes,

does your .out files contain some warnings? could you send an extract of your .out file (max 97 kB)?

Bye

CFAlex November 20, 2009 02:13

another error
 
I don't even get a .out-file. Error message is "The CFX solver for system 'modelname' did not produce a results file. No output is available. Cell A5"

Any ideas?

Fatnes November 20, 2009 02:37

1 Attachment(s)
I've talked with ANSYS Support and they can't help much about the error code. According to them their error codes are very general. In my case the solver runs smootly, converging within the first coeff. loop in every timestep, but suddenly it get convergense problems. After a few timesteps the solver stops with the following message (see attachment)

nellio75 November 20, 2009 05:00

Hello,

It could be a problem of memory : what is your physical memory on which type of machine? example : Linux with 2 Dual core (2.4MHz) 8GB ram : could you tell me what are the characteristics on your machine and what kind of calculation are you running : is it a parallel local PVM methode ? with how many partitions?
And during the 15 Timesteps look at the memory used by your solver? How much?

Bye

Bye

joey2007 November 21, 2009 11:37

255 may be some network error with parallelization. If you start a second run with exactly same settings, crashes again?

mehrdadeng November 23, 2009 13:30

hi dears
i have this error too.my hardware is:
4 Gb ram - cpu: intel quad 4000

it worked correctly.but i dont know that why this erro occurs.

mehrdadeng November 23, 2009 13:46

i thought the error be due to runing the simulation with previous parameters.
i changed inlet boundry condition but dont solve this error.
this error is displayed when out file comes to "solve" in cfx-solver monitors
i was ran this simululation with mpi parallel method but now this error occurs
how can solve this error
below posts display my simulation information


please remark

mehrdadeng November 23, 2009 15:57

2 Attachment(s)
this simulation is consist of 2 domain .blade domain(az immers domain) and housing domain(az fluid domain)

mehrdadeng November 23, 2009 16:05

3 Attachment(s)
domains parameters:
further more i tested solid domain instead of immerse domain but occurs above mentioned error

mehrdadeng November 23, 2009 16:09

3 Attachment(s)
housing doman information:

mehrdadeng November 23, 2009 16:15

3 Attachment(s)
inlet boundry condition:
inlet and outlet boundry condition has been defined on housing domain(fluid domain)

mehrdadeng November 23, 2009 16:21

4 Attachment(s)
outlet boundry condition and solver control parameters:

mehrdadeng November 23, 2009 16:23

how can solve this problem?

mehrdadeng November 23, 2009 16:35

1 Attachment(s)
messages that have been appeared in cfx-pre.i dont know couse of this messages because i defined only rotation for immerse domain but message says that ...

yochule April 9, 2010 16:28

the same problem
 
i'm having the same problem. with the same sign. i start running a case and i saw all the monitors decreasing smothly....but in any time the cfx-solver stop with this 255 error code.
i think is a strange error, because if i change an imput parameter just a little (ie: 4 to 5 m/s inlet, or 100 to 105 rpm) the solution converge.
so, i try changing some parameters. but i know that this is not the solution of this problem....
can you fix it?
regards

ghorrocks April 10, 2010 06:36

It almost certainly means the solver has diverged. In fact the divergence is bad enough that it got a divide by zero error and crashed the solver. You will need to improve the numerical stability of the solution.

salilharris2 August 29, 2010 10:44

Same problem here
 
I am doing flow analysis of a mixed flow compressor. It basically has a centrifugal impeller. I get the same error code 255 with no output file generated.

Only the 'dx' and 'dy' comes in the equation. If a divide by zero error comes, the problem should lie in the meshing. Any other suggestion???

If a divergence comes, the design values may not be right... A few changes should rectify the problem.

But my problem is that, with the same design values, i can generate results in fluent... why not in cfx...

And what exactly is this error???

The above mentioned posts are not much convincing

salilharris2 August 29, 2010 18:30

Problem resolved
 
In my case of mixed flow compressor, i had to entered mass flow rate through out the coImpressor. Instead i had to enter flow through the passage.

eg:- no. of blades - 22
total mass flow rate - 2.7
mass flow per passage - 2.7/22

with all the other conditions correct, the heavy mass flow rate of 2.7 per passage, was reducing the numerical stability of the problem.

Considering the CFD equations for turbo machines, the mass flow rate comes along with the constants. This error has made the numerator very high and denominator remains very small for fine meshing; resulting in high divergence of the equations. So, the software gave me an error code 255, terminating the iterations. This error should be because of huge divergence. Not necessarily divide by zero.

error code 255 in cfx is caused due to numerical instability of the equations. The above post is right. But many meanings are there to numerical instability. Since every case is different

jakubas September 24, 2010 04:31

I have the same error while modeling reacting flow for coal gasification. Slight change in mass flow rates leads to crush. After changing parameteres to previous values (or much higher values) CFX cannot converge. In my case calculations are terminated at 7-9th iteration

salilharris2 September 24, 2010 06:48

Your problem should be numerical instability.

The denominator consists of dx and dy terms which create instability when meshing is improper. The numerator consists of terms which contains terms like velocity, mass, temperature etc. When the values go beyond a certain limit, it destroys the stability of the system of equations.

Another way of loosing the numerical stability is when the continuity, momentum, energy and mass transport equations are solved together, the convergence of one equation depends on the equation above it. There can be convergence problems when all these equations are solved together.

In your case, one or more of your values are somewhere outside the limits. Try optimizing your values to get a numerically stable system of equations.
I hope this solves your problems...

Daniel Leite Oliveira June 15, 2011 09:49

I had the same error...
I've changed the Run Mode from MPICH2 Local Parallel to HP MPI Local Parallel and now it's gone

See you

hota January 15, 2013 09:47

Error message CFX Solver
 
this error message means a divergance in your solver, mostly cause of bad configurations in your presolver part, some times it happen cause of wrong or bad Boundary Conditions, bad B.C. some times produce zero denominators and make the solver diverge at the begining, my experiance is about Opening BC in CFX, where i chose Opening pressure and Dirn, and in direction part i chose cartesian components, then i entered a direction which was totaly tangent to my Boundary, so when i started the solver, it showed me Code1 or Code 255 as divergance alarm, look at your BC more carefully,
regards, ^_^

PYJG November 29, 2013 16:46

Fixed the issue
 
I had this error and was able to fix it....It was caused by antivirus deleting the mpid.exe file from the installation directory. Make sure this file exist there. Thanks.

ghorrocks November 30, 2013 04:36

Wow, that is one evil antivirus you have there.

dengemunzur July 3, 2015 10:32

CFX does not produce .res file when stop the run
 
Hi to all,

I am having a problem with CFX. When I try to stop run, CFX ends it but does not produce a result file. The problem is that everything goes well, the solution converges, also monitor point Iadded. when I stop the run, I face the warning "the cfx solver for system fluid flow did not produce a results file".

I tried to find a solution but could not achieve. By the way, I work on workbench.

Any idea?

Thanks

Best regards


All times are GMT -4. The time now is 18:20.