CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   CFX 12 on windows vista: problem with hp-mpi local parallel (

matheusguzella February 2, 2010 11:29

CFX 12 on windows vista: problem with hp-mpi local parallel

I'm working with the version 12 of CFX on my University but I'm receiving an error message when I try to run a simulation using hp-mpi local parallel. The message is related to error 255 and it seems that is not possible to make the connection. If I try to simulate using serial (run mode) it works perfectly. Does anyone know if this is a problem related to windows vista (this is the currently SO on the computer).

Thanks (again).

ghorrocks February 2, 2010 18:01

V12 is fully supported on Vista. Have you read the section in the documentation about setting up parallel simulations?

matheusguzella February 3, 2010 11:31

Yeah.. I'm familiar with the settings related to parallel simulation (I have 2 years of experience on mesh generation and CFX), but are you saying about some specific option or in general? Just tried the other parallel configuration (MPICH - local) and the program returned an ERROR CODE 255. I already tried to reinstall but nothing changed. I'm kind of lost..

ghorrocks February 3, 2010 23:32

The documentation has an extensive discussion of parallel setup and trouble shooting. That is the place to start.

Can you run local parallel? Which parallel options don't work? Try all available options - PVM, MPICH, HP MPI. That can give you some clues about what is wrong.

peaksun February 4, 2010 09:52

I met similar problems when using cfx12 under windows server 2003.

I could use 'MPICH2 Local Parallel' mode after I started the MPICH2 service, but the HP-MPI Local Parallel mode could not be activated even the system showed that HP-MPI service is started and run. Can anyone help to figure the problem out?:(

matheusguzella February 4, 2010 11:04

No.. that's the problem.. is not working the local parallel configuration. I tried MPICH2 and HP MPI (there isn't the PVM option like in CFX 11) and they are not working.. I will try to look for a solution in the documentation.. But it's difficult because I can't see why it's not running..

All times are GMT -4. The time now is 13:49.