CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Windows to Linux => END problems... (

zboud February 4, 2010 10:03

Windows to Linux => END problems...
Hi everyone,

I have a problem with the CFX solver. When I run a case that was defined on a Windows machine on my Linux computer, I get this error:

ccl2flow: * command language error *
Message: parseCCLLineH: unmatched END
Context: returned by cclApi call

Knowing that might come from the transfer of the .def file from Windows to Linux, I re-defined my .cfx file and generated the .def on the Linux machine. I thought this would work, but then I got this error:

ccl2flow: * command language error *
Message: 3 missing END statement(s) in input
Context: returned by cclApi call

I do not understand...could this come from the fact that in both cases, my mesh was defined on a Windows machine?

I did not check every END statement in the .def files because it's quite boring, and adding manually the missing ENDs will be quite annoying if I have to do it for each case I have to compute...

I tried changing the boundary conditions, but it did not change anything.

Here's some info about the setups: Windows Vista is used and both machines run CFX 12.0.

Thanks in advance for your help!

ckleanth February 4, 2010 13:45

the ccl for both windows and linux should be the same

it is more likely that your file is corrupted or the ccl was wrong to start with. best is to make sure it works in windows, export all ccl then you can check it in linux.

it shouldnt matter where you want to run the simulation if you already import a mesh in the def file

zboud February 4, 2010 14:38

I just tried to run the same files on both machines, it works in Windows, but not in Linux.

Files have been copied using WinSCP, binary mode. Seems like nothing is corrupted.

I might have just found the problem though: my Linux machine is running CFX-12.0.1 build 2009.04.14-22.59, whereas CFX-12.0.1 build 2009.04.14-23.02 is running in Windows...could it be the source of the problem?! That would not explain why a run defined from scratch (but the mesh) on my Linux computer is also erroneous...


ghorrocks February 4, 2010 17:26

I would load it into CFX-Pre. That should give you an idea of where the CCL error is. When fixed it will also regenerate the def file and it will probably work fine.

zboud February 4, 2010 17:53

I found where the problem came from. Looks like the installation of the CFX solver on the Linux machine was not done properly: I ran the case which was copied from my Windows laptop on another Linux machine, and everything worked fine. And my machine was not the only one with the problem. In the end I lost more than a day, but I gave some work to do to the tech guys ^^

Thanks for your answers! :)

All times are GMT -4. The time now is 04:51.