CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Remeshing-Solver Problem (

uorinopuot February 13, 2010 17:51

Remeshing-Solver Problem

I am modelling a throttle valve. The motion of the valve is coupled with the flow and there is a monitor point at the edge of it through which i measure the angle at which the valve has turned. When my simulation crashes due to negative volumes, I see the last set of results and create a new mesh to run the simulation again from where it stopped. Now, i also define in the run the initial values specification from my last results.

The problem now is that the solver starts and at some point has a very abnormal behaviour. In any monitor point i have the value starts to oscillate very slightly in the beginning and after some timesteps the oscillation is really severe.

I tried changing the timestep and the accuracy of the solver but there was no change. I also tried to run an earlier remeshing step which had worked, without making any changes, but now it did not work and the behaviour was the same.

Has anyone seen this before? Any help would be greatly appreciated.
Thank you.

ghorrocks February 14, 2010 06:30

Could it be that your valve motion is numerically unstable? You may need to put some damping in the motion. There is also a chance that this is physically real.

uorinopuot February 14, 2010 11:04

Hi. I thought about this behaviour to be physically real. However, i do not always get it. I went back and rerun earlier simulations which had run without these oscillations. Plus the results i get when this happens are completely different from what i expect. For example i have pressures of 10^5 magnitude in one timestep and -10^5 at the other which in my model i know shouldnt be happening.

ghorrocks February 14, 2010 18:35

That sounds like a numeric instability. Try to add some damping into the motion - for instance the shaft will have friction so damping does have a physical basis.

This sort of thing can also be linked to the simulation time step. Have you checked your time step is fine enough?

uorinopuot February 15, 2010 23:15

You were right. I was using a timestep of 5*10^-4 and i tried 1*10^-4. It seems to work.

I greatly appreciated your help.
Thank you.

All times are GMT -4. The time now is 12:02.