CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Problem with axial alignment in Turbomachinery (

zhaowei April 23, 2010 06:54

Problem with axial alignment in Turbomachinery
5 Attachment(s)
Hi all,

I am new to ansys cfx. I want to simulate coaxial propellers used as helicopter main rotors. When I usually set up the boundary condition manually, but I always fail for this problem, so I tried the turbomachinery simulation type. But I got a frustrating problem in this process.:confused::confused:

I set up four domains in the simulation, Inflow, upRotor, lowRotor, and Outflow (Figure 1). But when I perform the "Axial Alignment" (Figure 2), I found that the the S1 and S2 parts separate with the rotation parts (R1 and R2) (Figure 3). If I don't perform "Axial Alignment" and go on with the next step, the interfaces between S1/R1 and S2/R2 are not recognized automatically (Figure 4). The boundary condition is recognized as in Figure 5. If I just deleted these boundary conditions and set up the interface manually, everything is OK. But when I perform the simulation, I get an error as shown in Figure 6. Is there anyone could be of help with such problem? Thanks in advance.

The mesh size for S1 and S2 are as follows:
Global Mesh Setup: 500
Boundary and Inlet: 500
Interface: 20

The mesh size for R1 and R2 are as follows:
Global Mesh Setup: 100
Boundary: 30
Interface: 40
Mesh Blade: 30

zhaowei April 23, 2010 06:55

Figure 6
1 Attachment(s)
Figure 6, Thanks.

ghorrocks April 26, 2010 18:58

Increase the stack size as the error message suggests. You do this at run-time (ie in solver manager or when you fire off the job from the command line).

zhaowei April 28, 2010 07:12

2 Attachment(s)
Thanks very much, Glenn

I have changed the memory control / topology estimate factor to be 1.2. But I still got insufficient memory error. See the error in the figure and output file. I have found the link below:
It seems that this will happen because of the windows 32 bit os. So, should I change it to be 64 bit version and increase the RAM?


ghorrocks April 28, 2010 09:11

Keep increasing the stack until it is happy.

But if you have to increase beyond about 1.5 then it means something is seriously wrong. Something in your simulation means the memory estimate is way wrong and is probably not working properly.

zhaowei April 28, 2010 10:09

Thanks very much for your quick answer, Glenn. I have increased the memory control to be 2, but the error still exists. What do you think it will be the reason, mesh, domain interface set-up? Or should I try this another computer?


ghorrocks April 29, 2010 08:21

There will be no difference on another computer. This problem comes up when the GGI is not working properly, or some other physics is not functioning correctly.

zhaowei April 29, 2010 09:11

Glenn, Thanks very much, sincerely.

Attesz April 29, 2010 09:25

How many elements do you have in your simulation? Any how many RAM do you have? on 32bit, you can use about 2-2.3million element for 3GB RAM. (I was worked on a same project.)

zhaowei April 29, 2010 09:53

I use a coarse mesh at present, so the total cells is about 800k, my desktop at present has 2GB RAM. I have not determined what is the problem.

Attesz April 29, 2010 09:54

800k should run on 2GB. There is other problem.

zhaowei April 29, 2010 11:32

i think so too, thanks, Attila.

zhaowei May 4, 2010 05:14


u r completely right. the memory control is not defined properly, thanks.

All times are GMT -4. The time now is 22:34.